Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | require gstreamer1.0-plugins-common.inc |
| 2 | |
| 3 | LICENSE = "GPLv2+ & LGPLv2+" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 5 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 6 | SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-${PV}.tar.xz \ |
| 7 | file://0001-ENGR00312515-get-caps-from-src-pad-when-query-caps.patch \ |
| 8 | file://0003-viv-fb-Make-sure-config.h-is-included.patch \ |
| 9 | file://0002-ssaparse-enhance-SSA-text-lines-parsing.patch \ |
| 10 | file://0004-glimagesink-Downrank-to-marginal.patch \ |
| 11 | " |
Andrew Geissler | c723b72 | 2021-01-08 16:14:09 -0600 | [diff] [blame] | 12 | SRC_URI[sha256sum] = "dd04fb1f7826e2f6d9b4d66fc22f19cc6a47c301e13041f0ee3d7f65c89b05ac" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | |
| 14 | S = "${WORKDIR}/gst-plugins-base-${PV}" |
| 15 | |
| 16 | DEPENDS += "iso-codes util-linux zlib" |
| 17 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 18 | inherit gobject-introspection |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | |
| 20 | PACKAGES_DYNAMIC =+ "^libgst.*" |
| 21 | |
| 22 | # opengl packageconfig factored out to make it easy for distros |
| 23 | # and BSP layers to choose OpenGL APIs/platforms/window systems |
| 24 | PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}" |
| 25 | |
| 26 | PACKAGECONFIG ??= " \ |
| 27 | ${GSTREAMER_ORC} \ |
| 28 | ${PACKAGECONFIG_GL} \ |
| 29 | ${@bb.utils.filter('DISTRO_FEATURES', 'alsa x11', d)} \ |
| 30 | jpeg ogg pango png theora vorbis \ |
| 31 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', '', d)} \ |
| 32 | " |
| 33 | |
| 34 | OPENGL_APIS = 'opengl gles2' |
| 35 | OPENGL_PLATFORMS = 'egl' |
| 36 | |
| 37 | X11DEPENDS = "virtual/libx11 libsm libxrender libxv" |
| 38 | X11ENABLEOPTS = "-Dx11=enabled -Dxvideo=enabled -Dxshm=enabled" |
| 39 | X11DISABLEOPTS = "-Dx11=disabled -Dxvideo=disabled -Dxshm=disabled" |
| 40 | |
| 41 | PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib" |
| 42 | PACKAGECONFIG[cdparanoia] = "-Dcdparanoia=enabled,-Dcdparanoia=disabled,cdparanoia" |
| 43 | PACKAGECONFIG[jpeg] = "-Dgl-jpeg=enabled,-Dgl-jpeg=disabled,jpeg" |
| 44 | PACKAGECONFIG[ogg] = "-Dogg=enabled,-Dogg=disabled,libogg" |
| 45 | PACKAGECONFIG[opus] = "-Dopus=enabled,-Dopus=disabled,libopus" |
| 46 | PACKAGECONFIG[pango] = "-Dpango=enabled,-Dpango=disabled,pango" |
| 47 | PACKAGECONFIG[png] = "-Dgl-png=enabled,-Dgl-png=disabled,libpng" |
| 48 | PACKAGECONFIG[theora] = "-Dtheora=enabled,-Dtheora=disabled,libtheora" |
| 49 | PACKAGECONFIG[tremor] = "-Dtremor=enabled,-Dtremor=disabled,tremor" |
| 50 | PACKAGECONFIG[visual] = "-Dlibvisual=enabled,-Dlibvisual=disabled,libvisual" |
| 51 | PACKAGECONFIG[vorbis] = "-Dvorbis=enabled,-Dvorbis=disabled,libvorbis" |
| 52 | PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}" |
| 53 | |
| 54 | # OpenGL API packageconfigs |
| 55 | PACKAGECONFIG[opengl] = ",,virtual/libgl libglu" |
| 56 | PACKAGECONFIG[gles2] = ",,virtual/libgles2" |
| 57 | |
| 58 | # OpenGL platform packageconfigs |
| 59 | PACKAGECONFIG[egl] = ",,virtual/egl" |
| 60 | |
| 61 | # OpenGL window systems (except for X11) |
| 62 | PACKAGECONFIG[gbm] = ",,virtual/libgbm libgudev libdrm" |
| 63 | PACKAGECONFIG[wayland] = ",,wayland-native wayland wayland-protocols libdrm" |
| 64 | PACKAGECONFIG[dispmanx] = ",,virtual/libomxil" |
| 65 | |
| 66 | OPENGL_WINSYS_append = "${@bb.utils.contains('PACKAGECONFIG', 'x11', ' x11', '', d)}" |
| 67 | OPENGL_WINSYS_append = "${@bb.utils.contains('PACKAGECONFIG', 'gbm', ' gbm', '', d)}" |
| 68 | OPENGL_WINSYS_append = "${@bb.utils.contains('PACKAGECONFIG', 'wayland', ' wayland', '', d)}" |
| 69 | OPENGL_WINSYS_append = "${@bb.utils.contains('PACKAGECONFIG', 'dispmanx', ' dispmanx', '', d)}" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 70 | OPENGL_WINSYS_append = "${@bb.utils.contains('PACKAGECONFIG', 'egl', ' egl', '', d)}" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 71 | |
| 72 | EXTRA_OEMESON += " \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 73 | -Ddoc=disabled \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 74 | -Dgl-graphene=disabled \ |
| 75 | ${@get_opengl_cmdline_list('gl_api', d.getVar('OPENGL_APIS'), d)} \ |
| 76 | ${@get_opengl_cmdline_list('gl_platform', d.getVar('OPENGL_PLATFORMS'), d)} \ |
| 77 | ${@get_opengl_cmdline_list('gl_winsys', d.getVar('OPENGL_WINSYS'), d)} \ |
| 78 | " |
| 79 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 80 | FILES_${PN}-dev += "${libdir}/gstreamer-1.0/include/gst/gl/gstglconfig.h" |
| 81 | FILES_${MLPREFIX}libgsttag-1.0 += "${datadir}/gst-plugins-base/1.0/license-translations.dict" |
| 82 | |
| 83 | def get_opengl_cmdline_list(switch_name, options, d): |
| 84 | selected_options = [] |
| 85 | if bb.utils.contains('DISTRO_FEATURES', 'opengl', True, False, d): |
| 86 | for option in options.split(): |
| 87 | if bb.utils.contains('PACKAGECONFIG', option, True, False, d): |
| 88 | selected_options += [option] |
| 89 | if selected_options: |
| 90 | return '-D' + switch_name + '=' + ','.join(selected_options) |
| 91 | else: |
| 92 | return '' |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 93 | |
| 94 | CVE_PRODUCT += "gst-plugins-base" |