blob: c9063bc4458cb3b41ec97f910d709658e75717ce [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DDESCRIPTION = "A theme for exquisite"
2LICENSE = "MIT & BSD"
3LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=f523ab5986cc79b52a90d2ac3d5454a2"
4SECTION = "x11"
5DEPENDS = "edje-native"
6PV = "1.0+svnr${SRCPV}"
7SRCREV = "${EFL_SRCREV}"
8
9inherit e-base update-alternatives allarch
10
11ALTERNATIVE_NAME = "exquisite-config"
12ALTERNATIVE_LINK = "${sysconfdir}/exquisite/config"
13ALTERNATIVE_PATH = "${sysconfdir}/exquisite/config-illume"
14ALTERNATIVE_PRIORITY = "10"
15
16SRCNAME = "b_and_w"
17
18SRC_URI = "${E_SVN}/trunk/THEMES;module=${SRCNAME};protocol=http \
19 file://LICENSE \
20"
21S = "${WORKDIR}/${SRCNAME}"
22
23do_compile() {
24 ${STAGING_BINDIR_NATIVE}/edje_cc exquisite.edc illume.edj
25}
26
27do_install() {
28 install -d ${D}${sysconfdir}/exquisite
29 install -d ${D}${datadir}/exquisite/data/themes
30 install -m 0644 ${S}/illume.edj ${D}${datadir}/exquisite/data/themes/
31 echo 'THEME="-t illume"' > ${D}${sysconfdir}/exquisite/config-illume
32}
33
34CONFFILES_${PN} = "${sysconfdir}/exquisite/config-illume"
35FILES_${PN} = "${sysconfdir}/exquisite ${datadir}/exquisite/data/themes"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050036
37PNBLACKLIST[exquisite-theme-illume] ?= "Depends on blacklisted edje-native - the recipe will be removed on 2017-09-01 unless the issue is fixed"
38
39PNBLACKLIST[exquisite-theme-illume] ?= "Runtime depends on blacklisted exquisite-theme-illume - the recipe will be removed on 2017-09-01 unless the issue is fixed"
40
41PNBLACKLIST[exquisite-theme-illume] ?= "Runtime depends on blacklisted exquisite-theme-illume-dev - the recipe will be removed on 2017-09-01 unless the issue is fixed"