blob: 47e8f38e953d74b87cee9a51404ba2b72306b791 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Systemd service for kodi startup"
2
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
5
6PV = "1.0"
7
8SRC_URI = "file://kodi.service"
9
10inherit systemd
11
12do_install() {
13 install -d ${D}/lib/systemd/system
14 install -m 0644 ${WORKDIR}/kodi.service ${D}/lib/systemd/system/
15}
16
17SYSTEMD_PACKAGES = "${PN}"
18SYSTEMD_SERVICE_${PN} = "kodi.service"
19
20RDEPENDS_${PN} += "xinit kodi"
21
22PNBLACKLIST[kodi-startup] ?= "Runtime depends on blacklisted kodi - the recipe will be removed on 2017-09-01 unless the issue is fixed"
23
24PNBLACKLIST[kodi-startup] ?= "Runtime depends on blacklisted kodi-startup-dev - the recipe will be removed on 2017-09-01 unless the issue is fixed"