Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Systemd service for kodi startup" |
| 2 | |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690" |
| 5 | |
| 6 | PV = "1.0" |
| 7 | |
| 8 | SRC_URI = "file://kodi.service" |
| 9 | |
| 10 | inherit systemd |
| 11 | |
| 12 | do_install() { |
| 13 | install -d ${D}/lib/systemd/system |
| 14 | install -m 0644 ${WORKDIR}/kodi.service ${D}/lib/systemd/system/ |
| 15 | } |
| 16 | |
| 17 | SYSTEMD_PACKAGES = "${PN}" |
| 18 | SYSTEMD_SERVICE_${PN} = "kodi.service" |
| 19 | |
| 20 | RDEPENDS_${PN} += "xinit kodi" |
| 21 | |
| 22 | PNBLACKLIST[kodi-startup] ?= "Runtime depends on blacklisted kodi - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
| 23 | |
| 24 | PNBLACKLIST[kodi-startup] ?= "Runtime depends on blacklisted kodi-startup-dev - the recipe will be removed on 2017-09-01 unless the issue is fixed" |