blob: a08ea98acac791f89cdca1abc674d880d46738b5 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "A module to control Raspberry Pi GPIO channels"
2HOMEPAGE = "http://code.google.com/p/raspberry-gpio-python/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=9b95630a648966b142f1a0dcea001cb7"
6
7SRCNAME = "RPi.GPIO"
8
9SRC_URI = "\
10 http://pypi.python.org/packages/source/R/RPi.GPIO/${SRCNAME}-${PV}.tar.gz \
11 file://0001-Remove-nested-functions.patch \
12 "
13SRC_URI[md5sum] = "9db86fd5f3bae872de9dbb068ee0b096"
14SRC_URI[sha256sum] = "82acff0ef6bbe3cdf6f4dbdd73d96add5294bb94baf7f51c1d901861af3c2392"
15
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18inherit distutils
19
20COMPATIBLE_MACHINE = "raspberrypi"
21