Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 1 | SUMMARY = "Asio is C++ library for network and low-level I/O programming" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 2 | DESCRIPTION = "Asio is a cross-platform C++ library for network and low-level \ |
| 3 | I/O programming that provides developers with a consistent asynchronous \ |
| 4 | model using a modern C++ approach." |
| 5 | AUTHOR = "Christopher M. Kohlhoff (chris at kohlhoff dot com)" |
| 6 | HOMEPAGE = "http://think-async.com/Asio" |
| 7 | SECTION = "libs" |
| 8 | LICENSE = "BSL-1.0" |
| 9 | |
| 10 | DEPENDS = "openssl" |
| 11 | |
| 12 | SRC_URI = "${SOURCEFORGE_MIRROR}/asio/${BP}.tar.bz2" |
| 13 | |
| 14 | inherit autotools |
| 15 | |
| 16 | ALLOW_EMPTY_${PN} = "1" |
| 17 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 18 | LIC_FILES_CHKSUM = "file://COPYING;md5=de86c8210a433f72bd3cc98e797a6084" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 19 | |
Andrew Geissler | 72956ed | 2021-01-08 16:11:14 -0600 | [diff] [blame] | 20 | SRC_URI[md5sum] = "00807b2e976f467b3cec85d1589f0825" |
| 21 | SRC_URI[sha256sum] = "4af9875df5497fdd507231f4b7346e17d96fc06fe10fd30e2b3750715a329113" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | |
| 23 | SRC_URI = "${SOURCEFORGE_MIRROR}/asio/${BP}.tar.bz2" |
| 24 | |
| 25 | PACKAGECONFIG ??= "boost" |
| 26 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 27 | PACKAGECONFIG[boost] = "--with-boost=${STAGING_LIBDIR},--without-boost,boost" |
| 28 | |
| 29 | BBCLASSEXTEND = "native nativesdk" |