blob: 8190a5e3a5168df7278dd162800e7b5413a8e450 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Bash Automated Testing System"
2DESCRIPTION = "Bats is a TAP-compliant testing framework for Bash. It \
3provides a simple way to verify that the UNIX programs you write behave as expected."
4AUTHOR = "Sam Stephenson & bats-core organization"
5HOMEPAGE = "https://github.com/bats-core/bats-core"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b"
8
9SRC_URI = "git://github.com/bats-core/bats-core.git \
10 "
Andrew Geisslere34f8962021-04-15 15:53:51 -050011# v1.3.0
12SRCREV = "9086c47854652f2731861b40385689c85f12103f"
Brad Bishop26bdd442019-08-16 17:08:17 -040013
14S = "${WORKDIR}/git"
15
16do_install() {
17 # Just a bunch of bash scripts to install
18 ${S}/install.sh ${D}${prefix}
19}
20
Andrew Geisslere34f8962021-04-15 15:53:51 -050021RDEPENDS_${PN} = "bash"
22FILES_${PN} += "${libdir}/bats-core/*"
23
24PACKAGECONFIG ??= "pretty"
25PACKAGECONFIG[pretty] = ",,,ncurses"