Patrick Williams | e69d235 | 2017-02-23 20:56:04 -0600 | [diff] [blame] | 1 | SUMMARY = "Native Linux KVM tool" |
| 2 | DESCRIPTION = "kvmtool is a lightweight tool for hosting KVM guests." |
| 3 | |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067" |
| 6 | |
| 7 | DEPENDS = "dtc libaio zlib" |
| 8 | |
| 9 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/will/kvmtool.git \ |
| 10 | file://external-crosscompiler.patch \ |
| 11 | " |
| 12 | |
| 13 | SRCREV = "0093df80d754e1a05b016e5a4ccd4b51a00c562c" |
| 14 | PV = "3.18.0+git${SRCREV}" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | EXTRA_OEMAKE='ARCH="${TARGET_ARCH}" V=1' |
| 19 | |
| 20 | do_install() { |
| 21 | install -d ${D}${bindir} |
| 22 | install -m 0755 ${S}/lkvm ${D}${bindir}/ |
| 23 | } |