Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | SUMMARY = "Provides a bridge between gconf and xsettings" |
| 2 | HOMEPAGE = "http://svn.o-hand.com/view/matchbox/trunk/settings-daemon/" |
| 3 | BUGTRACKER = "http://bugzilla.yoctoproject.org/" |
| 4 | LICENSE = "MIT-style" |
| 5 | LIC_FILES_CHKSUM = "file://xsettings-manager.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \ |
| 6 | file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b" |
| 7 | DEPENDS = "gconf glib-2.0 gtk+3" |
| 8 | SECTION = "x11" |
| 9 | |
| 10 | # SRCREV tagged 0.0.2 |
| 11 | SRCREV = "b2e5da502f8c5ff75e9e6da771372ef8e40fd9a2" |
| 12 | SRC_URI = "git://git.yoctoproject.org/xsettings-daemon \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 13 | file://addsoundkeys.patch \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 14 | file://70settings-daemon.sh \ |
| 15 | " |
| 16 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))" |
| 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | inherit autotools pkgconfig gconf distro_features_check |
| 21 | |
| 22 | FILES_${PN} = "${bindir}/* ${sysconfdir}" |
| 23 | |
| 24 | # Requires gdk-x11-2.0 which is provided by gtk when x11 in DISTRO_FEATURES |
| 25 | REQUIRED_DISTRO_FEATURES = "x11" |
| 26 | |
| 27 | do_install_append () { |
| 28 | install -d ${D}/${sysconfdir}/X11/Xsession.d |
| 29 | install -m 755 ${WORKDIR}/70settings-daemon.sh ${D}/${sysconfdir}/X11/Xsession.d/ |
| 30 | } |