Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 1 | SUMMARY = "Tool to access UFS (Universal Flash Storage) devices" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" |
| 4 | |
| 5 | PV = "1.6+git${SRCPV}" |
| 6 | |
| 7 | BRANCH ?= "dev" |
| 8 | |
| 9 | SRCREV = "a3cf93b66f4606a46354cf884d24aa966661f848" |
| 10 | |
| 11 | SRC_URI = "git://github.com/westerndigitalcorporation/ufs-utils.git;protocol=git;branch=${BRANCH} \ |
| 12 | file://0001-Replace-u_intXX_t-with-kernel-typedefs.patch \ |
| 13 | " |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CC="${CC}" CFLAGS="${CFLAGS}"" |
| 18 | |
| 19 | CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__ -D_GNU_SOURCE" |
| 20 | |
| 21 | do_configure() { |
| 22 | sed -i -e "s|-static$||g" ${S}/Makefile |
| 23 | } |
| 24 | |
| 25 | do_install() { |
| 26 | install -D -m 755 ${S}/ufs-utils ${D}${bindir}/ufs-utils |
| 27 | } |
| 28 | |
| 29 | PROVIDES += "ufs-tool" |
| 30 | |
| 31 | RPROVIDES_${PN} += "ufs-tool" |
| 32 | |