Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 1 | SUMMARY = "library to access web services that claim to be "RESTful"" |
| 2 | HOMPAGE = "https://wiki.gnome.org/Projects/Librest" |
| 3 | LICENSE = "LGPLv2.1" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1" |
| 5 | |
| 6 | GNOMEBASEBUILDCLASS = "autotools" |
| 7 | |
| 8 | DEPENDS = " \ |
| 9 | libxml2-native \ |
| 10 | glib-2.0-native \ |
| 11 | glib-2.0 \ |
| 12 | libsoup-2.4 \ |
| 13 | " |
| 14 | |
| 15 | inherit gnomebase gobject-introspection gtk-doc vala |
| 16 | |
| 17 | SRC_URI[archive.md5sum] = "ece4547298a81105f307369d73c21b9d" |
| 18 | SRC_URI[archive.sha256sum] = "0513aad38e5d3cedd4ae3c551634e3be1b9baaa79775e53b2dba9456f15b01c9" |
| 19 | |
| 20 | # * gnome environment requires libsoup build with in gnome PACKAGECONFIG |
| 21 | # * libsoup-gnome support was removed upstream three years ago [1] |
| 22 | # [1] https://gitlab.gnome.org/GNOME/librest/commit/8f904a8e2bb38a7bf72245cdf2f1ecad17e9a720 |
| 23 | EXTRA_OECONF = "--without-gnome" |
| 24 | |
| 25 | do_configure_prepend() { |
| 26 | # rest expects introspection.m4 at custom location (see aclocal.m4). |
| 27 | cp -f ${STAGING_DIR_TARGET}/${datadir}/aclocal/introspection.m4 ${S}/build |
| 28 | } |
| 29 | |
| 30 | do_compile_prepend() { |
| 31 | export GIR_EXTRA_LIBS_PATH="${B}/rest/.libs" |
| 32 | } |
| 33 | |