blob: a7eb4c849698d7bf0f3a8fa05ccdda48beb290a2 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "OpenSAF is an open source implementation of the SAF AIS specification"
2DESCRIPTION = "OpenSAF is an open source project established to develop a base platform \
3middleware consistent with Service Availability Forum (SA Forum) \
4specifications, under the LGPLv2.1 license. The OpenSAF Foundation was \
5established by leading Communications and Enterprise Computing Companies to \
6facilitate the OpenSAF Project and to accelerate the adoption of the OpenSAF \
7code base in commercial products. \
8The OpenSAF project was launched in mid 2007 and has been under development by \
9an informal group of supporters of the OpenSAF initiative. The OpenSAF \
10Foundation was founded on January 22nd 2008 with Emerson Network Power, \
11Ericsson, Nokia Siemens Networks, HP and Sun Microsystems as founding members."
12HOMEPAGE = "http://www.opensaf.org"
13SECTION = "admin"
14LICENSE = "LGPLv2.1"
15LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7"
16
17DEPENDS = "libxml2 python"
18TOOLCHAIN = "gcc"
19
20SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
21
22SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \
23 file://0001-configure-Pass-linker-specific-options-with-Wl.patch \
24 file://0001-configure-Disable-format-overflow-if-supported-by-gc.patch \
25 file://0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch \
26 file://0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch \
Brad Bishop26bdd442019-08-16 17:08:17 -040027 file://0001-Add-configure-time-check-for-gettid-API.patch \
Brad Bishop36a3e3e2019-10-02 13:29:27 -040028 file://0001-create_empty_library-Use-CC-variable-intead-of-hardc.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040029 "
Brad Bishope42b3e32020-01-15 22:08:42 -050030SRC_URI[md5sum] = "9b61df01d1a092101c4a626692edae19"
31SRC_URI[sha256sum] = "6da9af96e8ee58d11031d305bf4804a00deb6108e12e422722882a2091bd34bd"
Brad Bishopc342db32019-05-15 21:57:59 -040032
33inherit autotools useradd systemd pkgconfig
34
35USERADD_PACKAGES = "${PN}"
36GROUPADD_PARAM_${PN} = "-f -r opensaf"
37USERADD_PARAM_${PN} = "-r -g opensaf -d ${datadir}/opensaf/ -s ${sbindir}/nologin -c \"OpenSAF\" opensaf"
38
39SYSTEMD_SERVICE_${PN} += "opensafd.service"
40SYSTEMD_AUTO_ENABLE = "disable"
41
42PACKAGECONFIG[systemd] = ",,systemd"
43PACKAGECONFIG[openhpi] = "--with-hpi-interface=B03,,openhpi"
44PACKAGECONFIG[plm] = "--enable-ais-plm,--disable-ais-plm,libvirt openhpi"
45
46PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"
47
Brad Bishopc342db32019-05-15 21:57:59 -040048CPPFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation"
49CXXFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation -Wno-error=format-truncation="
50LDFLAGS += "-Wl,--as-needed -latomic -Wl,--no-as-needed"
51
52do_install_append() {
Brad Bishopc342db32019-05-15 21:57:59 -040053 rm -fr "${D}${localstatedir}/lock"
54 rm -fr "${D}${localstatedir}/run"
55 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
56 rmdir --ignore-fail-on-non-empty "${D}${datadir}/java"
57 if [ ! -d "${D}${sysconfdir}/init.d" ]; then
58 install -d ${D}${sysconfdir}/init.d
59 install -m 0755 ${B}/osaf/services/infrastructure/nid/scripts/opensafd ${D}${sysconfdir}/init.d/
60 fi
61}
62
Brad Bishop36a3e3e2019-10-02 13:29:27 -040063FILES_${PN} += "${libdir}/libSa*.so ${systemd_unitdir}/system/*.service"
64FILES_${PN}-dev += "${libdir}/libopensaf_core.so"
Brad Bishopc342db32019-05-15 21:57:59 -040065FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a"
66
67INSANE_SKIP_${PN} = "dev-so"
68
69RDEPENDS_${PN} += "bash python"
70
71# http://errors.yoctoproject.org/Errors/Details/186970/
Brad Bishop0f291cc2019-09-01 15:16:57 -040072COMPATIBLE_HOST_libc-musl = 'null'
Brad Bishop36a3e3e2019-10-02 13:29:27 -040073
74FILES_SOLIBSDEV = ""