Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenSAF is an open source implementation of the SAF AIS specification" |
| 2 | DESCRIPTION = "OpenSAF is an open source project established to develop a base platform \ |
| 3 | middleware consistent with Service Availability Forum (SA Forum) \ |
| 4 | specifications, under the LGPLv2.1 license. The OpenSAF Foundation was \ |
| 5 | established by leading Communications and Enterprise Computing Companies to \ |
| 6 | facilitate the OpenSAF Project and to accelerate the adoption of the OpenSAF \ |
| 7 | code base in commercial products. \ |
| 8 | The OpenSAF project was launched in mid 2007 and has been under development by \ |
| 9 | an informal group of supporters of the OpenSAF initiative. The OpenSAF \ |
| 10 | Foundation was founded on January 22nd 2008 with Emerson Network Power, \ |
| 11 | Ericsson, Nokia Siemens Networks, HP and Sun Microsystems as founding members." |
| 12 | HOMEPAGE = "http://www.opensaf.org" |
| 13 | SECTION = "admin" |
| 14 | LICENSE = "LGPLv2.1" |
| 15 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7" |
| 16 | |
| 17 | DEPENDS = "libxml2 python" |
| 18 | TOOLCHAIN = "gcc" |
| 19 | |
| 20 | SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}" |
| 21 | |
| 22 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \ |
| 23 | file://0001-configure-Pass-linker-specific-options-with-Wl.patch \ |
| 24 | file://0001-configure-Disable-format-overflow-if-supported-by-gc.patch \ |
| 25 | file://0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch \ |
| 26 | file://0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 27 | file://0001-Add-configure-time-check-for-gettid-API.patch \ |
Brad Bishop | 36a3e3e | 2019-10-02 13:29:27 -0400 | [diff] [blame] | 28 | file://0001-create_empty_library-Use-CC-variable-intead-of-hardc.patch \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 29 | " |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 30 | SRC_URI[md5sum] = "9b61df01d1a092101c4a626692edae19" |
| 31 | SRC_URI[sha256sum] = "6da9af96e8ee58d11031d305bf4804a00deb6108e12e422722882a2091bd34bd" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 32 | |
| 33 | inherit autotools useradd systemd pkgconfig |
| 34 | |
| 35 | USERADD_PACKAGES = "${PN}" |
| 36 | GROUPADD_PARAM_${PN} = "-f -r opensaf" |
| 37 | USERADD_PARAM_${PN} = "-r -g opensaf -d ${datadir}/opensaf/ -s ${sbindir}/nologin -c \"OpenSAF\" opensaf" |
| 38 | |
| 39 | SYSTEMD_SERVICE_${PN} += "opensafd.service" |
| 40 | SYSTEMD_AUTO_ENABLE = "disable" |
| 41 | |
| 42 | PACKAGECONFIG[systemd] = ",,systemd" |
| 43 | PACKAGECONFIG[openhpi] = "--with-hpi-interface=B03,,openhpi" |
| 44 | PACKAGECONFIG[plm] = "--enable-ais-plm,--disable-ais-plm,libvirt openhpi" |
| 45 | |
| 46 | PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" |
| 47 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 48 | CPPFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation" |
| 49 | CXXFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation -Wno-error=format-truncation=" |
| 50 | LDFLAGS += "-Wl,--as-needed -latomic -Wl,--no-as-needed" |
| 51 | |
| 52 | do_install_append() { |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 53 | rm -fr "${D}${localstatedir}/lock" |
| 54 | rm -fr "${D}${localstatedir}/run" |
| 55 | rmdir --ignore-fail-on-non-empty "${D}${localstatedir}" |
| 56 | rmdir --ignore-fail-on-non-empty "${D}${datadir}/java" |
| 57 | if [ ! -d "${D}${sysconfdir}/init.d" ]; then |
| 58 | install -d ${D}${sysconfdir}/init.d |
| 59 | install -m 0755 ${B}/osaf/services/infrastructure/nid/scripts/opensafd ${D}${sysconfdir}/init.d/ |
| 60 | fi |
| 61 | } |
| 62 | |
Brad Bishop | 36a3e3e | 2019-10-02 13:29:27 -0400 | [diff] [blame] | 63 | FILES_${PN} += "${libdir}/libSa*.so ${systemd_unitdir}/system/*.service" |
| 64 | FILES_${PN}-dev += "${libdir}/libopensaf_core.so" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 65 | FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a" |
| 66 | |
| 67 | INSANE_SKIP_${PN} = "dev-so" |
| 68 | |
| 69 | RDEPENDS_${PN} += "bash python" |
| 70 | |
| 71 | # http://errors.yoctoproject.org/Errors/Details/186970/ |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 72 | COMPATIBLE_HOST_libc-musl = 'null' |
Brad Bishop | 36a3e3e | 2019-10-02 13:29:27 -0400 | [diff] [blame] | 73 | |
| 74 | FILES_SOLIBSDEV = "" |