Brad Bishop | 36a3e3e | 2019-10-02 13:29:27 -0400 | [diff] [blame] | 1 | SUMMARY = "A small tool to read/write memory" |
Brad Bishop | 00ab237 | 2019-10-14 11:06:18 -0400 | [diff] [blame] | 2 | DESCRIPTION = "rwmem is a small tool for reading and writing device registers. \ |
| 3 | rwmem supports two modes: mmap mode and i2c mode. \ |
| 4 | \ |
| 5 | In mmap mode rwmem accesses a file by memory mapping it. \ |
| 6 | Using /dev/mem as the memory mapped file makes rwmem access memory and \ |
| 7 | can thus be used to access devices which have memory mapped registers. \ |
| 8 | \ |
| 9 | In i2c mode rwmem accesses an i2c peripheral by sending i2c messages to it." |
| 10 | |
Brad Bishop | 36a3e3e | 2019-10-02 13:29:27 -0400 | [diff] [blame] | 11 | LICENSE = "GPLv2+" |
| 12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 13 | |
| 14 | DEPENDS += "python3 python3-pybind11" |
| 15 | |
| 16 | PV .= "+git${SRCPV}" |
| 17 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 18 | SRCREV_rwmem = "3ec3e421211b58e766651c2e3a3a21acf14a1906" |
Brad Bishop | 36a3e3e | 2019-10-02 13:29:27 -0400 | [diff] [blame] | 19 | SRCREV_inih = "4b10c654051a86556dfdb634c891b6c3224c4109" |
| 20 | |
| 21 | SRCREV_FORMAT = "rwmem_inih" |
| 22 | |
| 23 | SRC_URI = " \ |
| 24 | git://github.com/tomba/rwmem.git;protocol=https;name=rwmem \ |
| 25 | git://github.com/benhoyt/inih.git;protocol=https;name=inih;nobranch=1;destsuffix=git/ext/inih \ |
| 26 | " |
| 27 | |
| 28 | S = "${WORKDIR}/git" |
| 29 | |
| 30 | inherit cmake pkgconfig |
| 31 | |
| 32 | do_install() { |
| 33 | install -D -m 0755 ${B}/bin/rwmem ${D}${bindir}/rwmem |
| 34 | install -D -m 0644 ${B}/lib/librwmem.a ${D}${libdir}/librwmem.a |
| 35 | } |