Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "ipmiutil is an easy-to-use set of IPMI server management utilities.\ |
| 2 | It can get/set sensor thresholds, automate SEL management, do SOL console, etc." |
| 3 | |
| 4 | DESCRIPTION = "The IPMI Management Utilities currently work with platforms that \ |
| 5 | support the IPMI 1.5 or 2.0 specification. IPMI servers can be managed\ |
| 6 | locally, or remotely via IPMI LAN, even when the OS or main CPU is not\ |
| 7 | functional.\n \ |
| 8 | The ipmiutil utilities will use an IPMI Driver, either the Intel IPMI package \ |
| 9 | (ipmidrvr, /dev/imb), MontaVista OpenIPMI (/dev/ipmi0), the valinux IPMI \ |
| 10 | Driver (/dev/ipmikcs), or the LANDesk ldipmi daemon. The ipmiutil utilities \ |
| 11 | can also use direct user-space I/Os in Linux or FreeBSD if no IPMI driver \ |
| 12 | is detected." |
| 13 | |
| 14 | HOMEPAGE = "http://ipmiutil.sourceforge.net" |
| 15 | LICENSE = "BSD-2-Clause" |
| 16 | LIC_FILES_CHKSUM = "file://COPYING;md5=626a5970304daa1fcb87f757fb42b795" |
| 17 | |
| 18 | DEPENDS += "openssl" |
| 19 | |
| 20 | PARALLEL_MAKE = "" |
| 21 | |
| 22 | SRC_URI = "${SOURCEFORGE_MIRROR}/ipmiutil/ipmiutil-${PV}.tar.gz \ |
| 23 | file://fix_systemd_path.patch \ |
| 24 | " |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 25 | SRC_URI[md5sum] = "292d6df25cad678bb27e5c8cdc6748f9" |
| 26 | SRC_URI[sha256sum] = "58ccdbd5755d7dd72478756715af09e9c73330dfad2b91dbf03d2ac504b301a3" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 27 | |
| 28 | inherit autotools-brokensep pkgconfig systemd |
| 29 | |
| 30 | PACKAGECONFIG ?= "lanplus gpl" |
| 31 | PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 32 | PACKAGECONFIG[systemd] = "--enable-systemd=${datadir}/${BPN}, --enable-systemd=no" |
| 33 | PACKAGECONFIG[sha256] = "--enable-sha256, --enable-sha256=no, openssl-native, openssl" |
| 34 | PACKAGECONFIG[lanplus] = "--enable-lanplus, --enable-lanplus=no, openssl-native, openssl" |
| 35 | PACKAGECONFIG[landesk] = "--enable-landesk, --enable-landesk=no" |
| 36 | PACKAGECONFIG[sensors] = "--enable-libsensors, --enable-libsensors=no" |
| 37 | |
| 38 | #build with some GPL code |
| 39 | PACKAGECONFIG[gpl] = "--enable-gpl, --enable-gpl=no" |
| 40 | #no GPL or LanPlus libs |
| 41 | PACKAGECONFIG[standalone] = "--enable-standalone, --enable-standalone=no" |
| 42 | |
| 43 | CFLAGS += "-I${STAGING_INCDIR}" |
| 44 | LDFLAGS += "-L${STAGING_LIBDIR}" |
| 45 | |
| 46 | COMPATIBLE_HOST = '(x86_64|i.86).*-linux' |