Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Monitor for system resources and process activity" |
| 2 | DESCRIPTION = "Atop is an ASCII full-screen performance monitor for Linux that \ |
| 3 | is capable of reporting the activity of all processes (even if processes have \ |
| 4 | finished during the interval), daily logging of system and process activity for \ |
| 5 | long-term analysis, highlighting overloaded system resources by using colors, \ |
| 6 | etc. At regular intervals, it shows system-level activity related to the CPU, \ |
| 7 | memory, swap, disks (including LVM) and network layers, and for every process \ |
| 8 | (and thread) it shows e.g. the CPU utilization, memory growth, disk \ |
| 9 | utilization, priority, username, state, and exit code." |
| 10 | HOMEPAGE = "http://www.atoptool.nl" |
| 11 | SECTION = "console/utils" |
| 12 | |
| 13 | LICENSE = "GPLv2" |
| 14 | LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833" |
| 15 | |
| 16 | DEPENDS = "ncurses zlib" |
| 17 | |
| 18 | SRC_URI = "http://www.atoptool.nl/download/${BP}.tar.gz \ |
| 19 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'file://volatiles.atop.conf', 'file://volatiles.99_atop', d)} \ |
| 20 | file://fix-permissions.patch \ |
| 21 | file://sysvinit-implement-status.patch \ |
| 22 | file://0001-atop.daily-atop.init-atop-pm.sh-Avoid-using-bash.patch \ |
| 23 | " |
| 24 | SRC_URI[md5sum] = "1077da884ed94f2bc3c81ac3ab970436" |
| 25 | SRC_URI[sha256sum] = "be1c010a77086b7d98376fce96514afcd73c3f20a8d1fe01520899ff69a73d69" |
| 26 | |
| 27 | do_compile() { |
| 28 | oe_runmake all |
| 29 | } |
| 30 | |
| 31 | do_install() { |
| 32 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 33 | make DESTDIR=${D} VERS=${PV} SYSDPATH=${systemd_system_unitdir} \ |
| 34 | PMPATHD=${systemd_unitdir}/system-sleep systemdinstall |
| 35 | install -d ${D}${sysconfdir}/tmpfiles.d |
| 36 | install -m 644 ${WORKDIR}/volatiles.atop.conf ${D}${sysconfdir}/tmpfiles.d/atop.conf |
| 37 | rm -f ${D}${systemd_system_unitdir}/atopacct.service |
| 38 | else |
| 39 | make DESTDIR=${D} VERS=${PV} sysvinstall |
| 40 | install -d ${D}${sysconfdir}/default/volatiles |
| 41 | install -m 644 ${WORKDIR}/volatiles.99_atop ${D}${sysconfdir}/default/volatiles/99_atop |
| 42 | rm -f ${D}${sysconfdir}/init.d/atopacct |
| 43 | fi |
| 44 | |
| 45 | # remove atopacct related files |
| 46 | rm -rf ${D}${sbindir} ${D}${mandir}/man8 |
| 47 | } |
| 48 | |
| 49 | inherit systemd |
| 50 | |
| 51 | SYSTEMD_SERVICE_${PN} = "atop.service atopgpu.service" |
| 52 | SYSTEMD_AUTO_ENABLE = "disable" |
| 53 | |
| 54 | FILES_${PN} += "${systemd_unitdir}/system-sleep" |
| 55 | |
| 56 | RDEPENDS_${PN} = "procps" |