Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | require ${BPN}.inc |
| 2 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 3 | DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 4 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 5 | inherit features_check binconfig lib_package gtk-icon-cache mime |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 6 | REQUIRED_DISTRO_FEATURES = "x11" |
| 7 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 8 | SRC_URI += " \ |
| 9 | file://0003-CMake-build-Force-shared-libs-with-unsuffixed-names.patch \ |
| 10 | file://0004-Fix-build-error-when-enable-package-config-examples.patch \ |
| 11 | " |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 12 | |
| 13 | EXTRA_OECMAKE = " \ |
| 14 | -DOPTION_BUILD_SHARED_LIBS=ON \ |
| 15 | -DOPTION_USE_THREADS=ON \ |
| 16 | -DOPTION_USE_XDBE=ON \ |
| 17 | -DOPTION_USE_XFT=ON \ |
| 18 | -DFLTK_CONFIG_PATH=${libdir}/cmake \ |
| 19 | " |
| 20 | |
| 21 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}" |
| 22 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 23 | PACKAGECONFIG[examples] = "-DOPTION_BUILD_EXAMPLES=ON,-DOPTION_BUILD_EXAMPLES=OFF,fltk-native" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 24 | PACKAGECONFIG[cairo] = "-DOPTION_CAIRO=ON,-DOPTION_CAIRO=OFF,cairo" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 25 | PACKAGECONFIG[opengl] = "-DOPTION_USE_GL=ON,-DOPTION_USE_GL=OFF,virtual/libgl" |
| 26 | PACKAGECONFIG[xinerama] = "-DOPTION_USE_XINERAMA=ON,-DOPTION_USE_XINERAMA=OFF,libxinerama" |
| 27 | PACKAGECONFIG[xfixes] = "-DOPTION_USE_XFIXES=ON,-DOPTION_USE_XFIXES=OFF,libxfixes" |
| 28 | PACKAGECONFIG[xcursor] = "-DOPTION_USE_XCURSOR=ON,-DOPTION_USE_XCURSOR=OFF,libxcursor" |
| 29 | |
| 30 | do_install_append() { |
| 31 | sed -i -e 's,${STAGING_DIR_HOST},,g' ${D}${bindir}/fltk-config |
| 32 | } |
| 33 | |
| 34 | python populate_packages_prepend () { |
| 35 | if (d.getVar('DEBIAN_NAMES')): |
| 36 | d.setVar('PKG_${BPN}', 'libfltk${PV}') |
| 37 | } |
| 38 | |
| 39 | LEAD_SONAME = "libfltk.so" |
| 40 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 41 | # .desktop / icons / mime only necessary for fluid app |
| 42 | FILES_${PN}-bin += " \ |
| 43 | ${datadir}/applications \ |
| 44 | ${datadir}/icons \ |
| 45 | ${datadir}/mime \ |
| 46 | " |
| 47 | |
| 48 | # cmake files |
| 49 | FILES_${PN}-dev += "${datadir}/fltk" |