Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "ImageMagick is an image conversion toolkit" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 2 | SECTION = "console/utils" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 3 | HOMEPAGE = "https://www.imagemagick.org/" |
| 4 | DESCRIPTION = "ImageMagick is a collection of tools for displaying, converting, and \ |
| 5 | editing raster and vector image files. It can read and write over 200 image file formats." |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 6 | LICENSE = "ImageMagick" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=41b4fa9af60c88e61484b02c0561181a" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 8 | # FIXME: There are many more checked libraries. All should be added or explicitly disabled to get consistent results. |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 9 | DEPENDS = "lcms bzip2 jpeg libpng tiff zlib fftw freetype libtool" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 10 | |
| 11 | BASE_PV := "${PV}" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 12 | PV .= "_13" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 13 | SRC_URI = "git://github.com/ImageMagick/ImageMagick.git " |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 14 | SRCREV = "15b935d64f613b5a0fc9d3fead5c6ec1b0e3908f" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit autotools pkgconfig update-alternatives |
| 19 | |
| 20 | # xml disabled because it's using xml2-config --prefix to determine prefix which returns just /usr with our libxml2 |
| 21 | # if someone needs xml support then fix it first |
| 22 | EXTRA_OECONF = "--program-prefix= --program-suffix=.im7 --without-perl --disable-openmp --without-xml --disable-opencl" |
| 23 | |
| 24 | CACHED_CONFIGUREVARS = "ac_cv_sys_file_offset_bits=yes" |
| 25 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" |
| 26 | PACKAGECONFIG[graphviz] = "--with-gvc,--without-gvc,graphviz" |
| 27 | PACKAGECONFIG[jp2] = "--with-jp2,,jasper" |
| 28 | PACKAGECONFIG[lzma] = "--with-lzma,--without-lzma,xz" |
| 29 | PACKAGECONFIG[openjpeg] = "--with-openjp2,--without-openjp2,openjpeg" |
| 30 | PACKAGECONFIG[pango] = "--with-pango,--without-pango,pango cairo" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 31 | PACKAGECONFIG[rsvg] = "--with-rsvg,--without-rsvg,librsvg" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 32 | PACKAGECONFIG[tcmalloc] = "--with-tcmalloc=yes,--with-tcmalloc=no,gperftools" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 33 | PACKAGECONFIG[webp] = "--with-webp,--without-webp,libwebp" |
| 34 | PACKAGECONFIG[wmf] = "--with-wmf,--without-wmf,libwmf" |
| 35 | PACKAGECONFIG[x11] = "--with-x,--without-x,virtual/libx11 libxext libxt" |
| 36 | |
| 37 | FILES_${PN} += "${libdir}/ImageMagick-${BASE_PV}/config-Q16* \ |
| 38 | ${datadir}/ImageMagick-7" |
| 39 | |
| 40 | FILES_${PN}-dev += "${libdir}/ImageMagick-${BASE_PV}/modules-Q16/*/*.a" |
| 41 | |
| 42 | FILES_${PN}-dbg += "${libdir}/ImageMagick-${BASE_PV}/modules-Q16/*/.debug/*" |
| 43 | |
| 44 | BBCLASSEXTEND = "native" |
| 45 | |
| 46 | ALTERNATIVE_PRIORITY = "100" |
| 47 | |
| 48 | ALTERNATIVE_${PN} = "animate compare composite conjure convert display \ |
| 49 | identify import mogrify montage stream" |
| 50 | |
| 51 | ALTERNATIVE_TARGET[animate] = "${bindir}/animate.im7" |
| 52 | ALTERNATIVE_TARGET[compare] = "${bindir}/compare.im7" |
| 53 | ALTERNATIVE_TARGET[composite] = "${bindir}/composite.im7" |
| 54 | ALTERNATIVE_TARGET[conjure] = "${bindir}/conjure.im7" |
| 55 | ALTERNATIVE_TARGET[convert] = "${bindir}/convert.im7" |
| 56 | ALTERNATIVE_TARGET[display] = "${bindir}/display.im7" |
| 57 | ALTERNATIVE_TARGET[identify] = "${bindir}/identify.im7" |
| 58 | ALTERNATIVE_TARGET[import] = "${bindir}/import.im7" |
| 59 | ALTERNATIVE_TARGET[mogrify] = "${bindir}/mogrify.im7" |
| 60 | ALTERNATIVE_TARGET[montage] = "${bindir}/montage.im7" |
| 61 | ALTERNATIVE_TARGET[stream] = "${bindir}/stream.im7" |
| 62 | |
| 63 | ALTERNATIVE_${PN}-doc = "animate.1 compare.1 composite.1 conjure.1 \ |
| 64 | convert.1 display.1 identify.1 import.1 mogrify.1 montage.1 stream.1" |
| 65 | |
| 66 | ALTERNATIVE_LINK_NAME[animate.1] = "${mandir}/man1/animate.1" |
| 67 | ALTERNATIVE_TARGET[animate.1] = "${mandir}/man1/animate.im7.1" |
| 68 | ALTERNATIVE_LINK_NAME[compare.1] = "${mandir}/man1/compare.1" |
| 69 | ALTERNATIVE_TARGET[compare.1] = "${mandir}/man1/compare.im7.1" |
| 70 | ALTERNATIVE_LINK_NAME[composite.1] = "${mandir}/man1/composite.1" |
| 71 | ALTERNATIVE_TARGET[composite.1] = "${mandir}/man1/composite.im7.1" |
| 72 | ALTERNATIVE_LINK_NAME[conjure.1] = "${mandir}/man1/conjure.1" |
| 73 | ALTERNATIVE_TARGET[conjure.1] = "${mandir}/man1/conjure.im7.1" |
| 74 | ALTERNATIVE_LINK_NAME[convert.1] = "${mandir}/man1/convert.1" |
| 75 | ALTERNATIVE_TARGET[convert.1] = "${mandir}/man1/convert.im7.1" |
| 76 | ALTERNATIVE_LINK_NAME[display.1] = "${mandir}/man1/display.1" |
| 77 | ALTERNATIVE_TARGET[display.1] = "${mandir}/man1/display.im7.1" |
| 78 | ALTERNATIVE_LINK_NAME[identify.1] = "${mandir}/man1/identify.1" |
| 79 | ALTERNATIVE_TARGET[identify.1] = "${mandir}/man1/identify.im7.1" |
| 80 | ALTERNATIVE_LINK_NAME[import.1] = "${mandir}/man1/import.1" |
| 81 | ALTERNATIVE_TARGET[import.1] = "${mandir}/man1/import.im7.1" |
| 82 | ALTERNATIVE_LINK_NAME[mogrify.1] = "${mandir}/man1/mogrify.1" |
| 83 | ALTERNATIVE_TARGET[mogrify.1] = "${mandir}/man1/mogrify.im7.1" |
| 84 | ALTERNATIVE_LINK_NAME[montage.1] = "${mandir}/man1/montage.1" |
| 85 | ALTERNATIVE_TARGET[montage.1] = "${mandir}/man1/montage.im7.1" |
| 86 | ALTERNATIVE_LINK_NAME[stream.1] = "${mandir}/man1/stream.1" |
| 87 | ALTERNATIVE_TARGET[stream.1] = "${mandir}/man1/stream.im7.1" |