Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Smart card library and applications" |
| 2 | DESCRIPTION = "OpenSC is a tool for accessing smart card devices. Basic\ |
| 3 | functionality (e.g. SELECT FILE, READ BINARY) should work on any ISO\ |
| 4 | 7816-4 compatible smart card. Encryption and decryption using private\ |
| 5 | keys on the smart card is possible with PKCS\ |
| 6 | such as the FINEID (Finnish Electronic IDentity) card. Swedish Posten\ |
| 7 | eID cards have also been confirmed to work." |
| 8 | |
| 9 | HOMEPAGE = "http://www.opensc-project.org/opensc/" |
| 10 | SECTION = "System Environment/Libraries" |
| 11 | LICENSE = "LGPLv2+" |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" |
| 13 | |
| 14 | #v0.19.0 |
| 15 | SRCREV = "f1691fc91fc113191c3a8aaf5facd6983334ec47" |
| 16 | SRC_URI = "git://github.com/OpenSC/OpenSC \ |
| 17 | file://0001-Remove-redundant-logging.patch \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 18 | file://0001-Fix-misleading-code-indentation.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 19 | " |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 20 | DEPENDS = "virtual/libiconv openssl" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 21 | |
| 22 | S = "${WORKDIR}/git" |
| 23 | inherit autotools pkgconfig bash-completion |
| 24 | |
| 25 | EXTRA_OECONF = " \ |
| 26 | --disable-static \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 27 | --disable-ctapi \ |
| 28 | --disable-doc \ |
| 29 | " |
| 30 | EXTRA_OEMAKE = "DESTDIR=${D}" |
| 31 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 32 | PACKAGECONFIG ??= "pcsc" |
| 33 | |
| 34 | PACKAGECONFIG[openct] = "--enable-openct,--disable-openct,openct" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 35 | PACKAGECONFIG[pcsc] = "--enable-pcsc,--disable-pcsc,pcsc-lite,pcsc-lite pcsc-lite-lib" |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 36 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 37 | RDEPENDS_${PN} = "readline" |
| 38 | |
| 39 | FILES_${PN} += "\ |
| 40 | ${libdir}/opensc-pkcs11.so \ |
| 41 | ${libdir}/onepin-opensc-pkcs11.so \ |
| 42 | ${libdir}/pkcs11-spy.so \ |
| 43 | " |
| 44 | FILES_${PN}-dev += "\ |
| 45 | ${libdir}/pkcs11/opensc-pkcs11.so \ |
| 46 | ${libdir}/pkcs11/onepin-opensc-pkcs11.so \ |
| 47 | ${libdir}/pkcs11/pkcs11-spy.so \ |
| 48 | " |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 49 | |
| 50 | BBCLASSEXTEND = "native" |