Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Tracker is a file search engine" |
| 2 | LICENSE = "GPL-2.0-only & LGPL-2.1-only" |
| 3 | LIC_FILES_CHKSUM = " \ |
| 4 | file://COPYING.GPL;md5=ee31012bf90e7b8c108c69f197f3e3a4 \ |
| 5 | file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \ |
| 6 | " |
| 7 | |
| 8 | DEPENDS = " \ |
| 9 | dbus-native \ |
| 10 | python3-pygobject-native \ |
| 11 | glib-2.0 \ |
| 12 | sqlite3 \ |
| 13 | libarchive \ |
| 14 | dbus \ |
| 15 | icu \ |
| 16 | json-glib \ |
| 17 | libsoup-3.0 \ |
| 18 | libstemmer \ |
| 19 | " |
| 20 | |
| 21 | GNOMEBASEBUILDCLASS = "meson" |
| 22 | |
| 23 | inherit gnomebase gsettings gobject-introspection vala gtk-doc manpages bash-completion features_check python3native |
| 24 | |
| 25 | SRC_URI[archive.sha256sum] = "4e6df142a4f704878fca98ebb5a224750e5ea546aa2aaabaa726a73540bd1731" |
| 26 | |
| 27 | # gobject-introspection is mandatory and cannot be configured |
| 28 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
| 29 | GIR_MESON_OPTION = "" |
| 30 | |
| 31 | # text search is not an option anymore and requires sqlite3 build with |
| 32 | # PACKAGECONFIG[fts5] set (default) |
| 33 | |
| 34 | # set required cross property sqlite3_has_fts5 |
| 35 | do_write_config[vardeps] += "PACKAGECONFIG" |
| 36 | do_write_config:append() { |
| 37 | echo "[properties]" > ${WORKDIR}/meson-tracker.cross |
| 38 | echo "sqlite3_has_fts5 = 'true'" >> ${WORKDIR}/meson-tracker.cross |
| 39 | } |
| 40 | |
| 41 | EXTRA_OEMESON = " \ |
| 42 | --cross-file ${WORKDIR}/meson-tracker.cross \ |
| 43 | -Dman=false \ |
| 44 | -Dsystemd_user_services=${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)} \ |
| 45 | -Dsystemd_user_services_dir=${systemd_user_unitdir} \ |
| 46 | -Dsoup=soup3 \ |
| 47 | " |
| 48 | |
| 49 | FILES:${PN} += " \ |
| 50 | ${datadir}/dbus-1 \ |
| 51 | ${datadir}/tracker3 \ |
| 52 | ${libdir}/tracker-3.0 \ |
| 53 | ${systemd_user_unitdir} \ |
| 54 | " |