Brad Bishop | 0e04b2e | 2019-05-13 13:45:49 -0400 | [diff] [blame] | 1 | SUMMARY = "Generate fan control YAML from the MRW" |
Brad Bishop | 0e04b2e | 2019-05-13 13:45:49 -0400 | [diff] [blame] | 2 | LICENSE = "Apache-2.0" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 3 | DEPENDS = "mrw-native mrw-perl-tools-native" |
| 4 | PROVIDES += "virtual/phosphor-fan-control-fan-config" |
| 5 | PR = "r1" |
| 6 | |
| 7 | S = "${WORKDIR}" |
Brad Bishop | 0e04b2e | 2019-05-13 13:45:49 -0400 | [diff] [blame] | 8 | |
| 9 | inherit allarch |
| 10 | inherit phosphor-fan |
| 11 | inherit mrw-xml |
| 12 | |
Brad Bishop | 0e04b2e | 2019-05-13 13:45:49 -0400 | [diff] [blame] | 13 | do_compile() { |
| 14 | ${bindir}/perl-native/perl \ |
| 15 | ${bindir}/gen_fan_zone_yaml.pl \ |
| 16 | -i ${STAGING_DIR_NATIVE}${mrw_datadir}/${MRW_XML} \ |
| 17 | -o fans.yaml |
| 18 | } |
Brad Bishop | 0e04b2e | 2019-05-13 13:45:49 -0400 | [diff] [blame] | 19 | do_install() { |
| 20 | install -D fans.yaml ${D}${control_datadir}/fans.yaml |
| 21 | } |
| 22 | |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 23 | FILES:${PN} += "${control_datadir}/fans.yaml" |