Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "mcelog daemon accounts memory and some other errors in various ways." |
| 2 | DESCRIPTION = "mcelog is required by both 32bit x86 Linux kernels (since 2.6.30) \ |
| 3 | and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks \ |
| 4 | and should run on all Linux systems that need error handling." |
| 5 | HOMEPAGE = "https://mcelog.org/" |
| 6 | SECTION = "System Environment/Base" |
| 7 | |
Patrick Williams | 4585273 | 2022-04-02 08:58:32 -0500 | [diff] [blame] | 8 | SRC_URI = "\ |
| 9 | git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http;;branch=master \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 10 | file://run-ptest \ |
Patrick Williams | 4585273 | 2022-04-02 08:58:32 -0500 | [diff] [blame] | 11 | file://0001-genconfig.py-update-shebang.patch \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 12 | " |
| 13 | |
| 14 | SRCREV = "4146c9296a0cbd26f1c5e411cb44877f350053bd" |
| 15 | |
| 16 | LICENSE = "GPL-2.0-only" |
| 17 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | inherit autotools-brokensep ptest |
| 22 | |
| 23 | COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux' |
| 24 | |
| 25 | do_install:append() { |
| 26 | install -d ${D}${sysconfdir}/cron.hourly |
| 27 | install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/ |
| 28 | sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron |
| 29 | } |
| 30 | |
| 31 | do_install_ptest() { |
| 32 | install -d ${D}${PTEST_PATH} |
| 33 | cp -r ${S}/tests ${S}/input ${D}${PTEST_PATH} |
| 34 | sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test |
| 35 | } |
| 36 | |
| 37 | RDEPENDS:${PN}-ptest += "make bash mce-inject" |