Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | DESCRIPTION = "\ |
| 2 | IPC::Run allows you run and interact with child processes \ |
| 3 | using files, pipes, and pseudo-ttys. Both system()-style and scripted \ |
| 4 | usages are supported and may be mixed. Likewise, functional and OO API \ |
| 5 | styles are both supported and may be mixed." |
| 6 | HOMEPAGE = "https://metacpan.org/release/IPC-Run" |
| 7 | SECTION = "libs" |
| 8 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0ebd37caf53781e8b7223e6b99b63f4e" |
| 10 | DEPENDS = "perl" |
| 11 | |
| 12 | SRC_URI = "git://github.com/toddr/IPC-Run.git;branch=master;protocol=https" |
| 13 | SRCREV = "44b1f2d2021615c88f2f6b1a6cbdd9aebaeb4ad1" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit cpan |
| 18 | |
| 19 | EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}" |
| 20 | |
| 21 | do_compile() { |
| 22 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 23 | cpan_do_compile |
| 24 | } |