Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 1 | SUMMARY = "Tools to manipulate UEFI variables" |
| 2 | DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility" |
| 3 | HOMEPAGE = "https://github.com/rhboot/efivar" |
| 4 | |
| 5 | LICENSE = "LGPLv2.1+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393" |
| 7 | |
| 8 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| 9 | |
| 10 | SRC_URI = "git://github.com/rhinstaller/efivar.git \ |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 11 | file://determinism.patch \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 12 | file://no-werror.patch" |
| 13 | SRCREV = "c1d6b10e1ed4ba2be07f385eae5bceb694478a10" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit pkgconfig |
| 18 | |
| 19 | export CCLD_FOR_BUILD = "${BUILD_CCLD}" |
| 20 | |
| 21 | # Upstream uses --add-needed in gcc.specs which gold doesn't support, so |
| 22 | # enforce BFD. |
| 23 | LDFLAGS += "-fuse-ld=bfd" |
| 24 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 25 | do_compile:prepend() { |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 26 | # Remove when https://github.com/rhboot/efivar/issues/130 is fixed |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 27 | oe_runmake \ |
| 28 | CFLAGS="${BUILD_CFLAGS}" \ |
| 29 | LDFLAGS="${BUILD_LDFLAGS}" \ |
| 30 | -C src makeguids |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 31 | } |
| 32 | |
| 33 | do_install() { |
| 34 | oe_runmake install DESTDIR=${D} |
| 35 | } |
| 36 | |
| 37 | BBCLASSEXTEND = "native" |
| 38 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 39 | RRECOMMENDS:${PN}:class-target = "kernel-module-efivarfs" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 40 | |
| 41 | CLEANBROKEN = "1" |