Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "CD/DVD command line tools" |
| 2 | HOMEPAGE = "http://cdrkit.org/" |
| 3 | |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b30d3b2750b668133fc17b401e1b98f8" |
| 6 | |
| 7 | # While writing download from cdrkit.org was broken so get sources from debian |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 8 | SRC_URI = "${DEBIAN_MIRROR}/main/c/${BPN}/${BPN}_${PV}.orig.tar.gz \ |
| 9 | file://0001-do-not-create-a-run-test-to-determine-order-of-bitfi.patch \ |
| 10 | file://0001-genisoimage-Fix-fprintf-format-errors.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 11 | file://0001-define-__THROW-to-avoid-build-issue-with-musl.patch \ |
| 12 | file://0002-Do-not-use-rcmd-on-build-with-musl.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 13 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 14 | SRC_URI[md5sum] = "efe08e2f3ca478486037b053acd512e9" |
| 15 | SRC_URI[sha256sum] = "d1c030756ecc182defee9fe885638c1785d35a2c2a297b4604c0e0dcc78e47da" |
| 16 | |
| 17 | inherit cmake |
| 18 | |
| 19 | DEPENDS = "libcap file bzip2" |
| 20 | RDEPENDS_${PN} = "perl" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 21 | |
| 22 | do_install_append() { |
| 23 | ln -sf ${bindir}/genisoimage ${D}${bindir}/mkisofs |
| 24 | } |