Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "GNU Privacy Guard - encryption and signing tools" |
| 2 | HOMEPAGE = "http://www.gnupg.org/" |
| 3 | DEPENDS = "zlib bzip2 readline" |
| 4 | SECTION = "console/utils" |
| 5 | |
| 6 | LICENSE = "GPLv2" |
| 7 | |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a" |
| 9 | |
| 10 | PR = "r9" |
| 11 | |
| 12 | SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-${PV}.tar.bz2 \ |
| 13 | file://long-long-thumb.patch \ |
| 14 | file://configure.patch \ |
| 15 | file://mips_gcc4.4.patch \ |
| 16 | file://GnuPG1-CVE-2012-6085.patch \ |
| 17 | file://curl_typeof_fix_backport.patch \ |
| 18 | file://CVE-2013-4351.patch \ |
| 19 | file://CVE-2013-4576.patch \ |
| 20 | file://CVE-2013-4242.patch \ |
| 21 | " |
| 22 | |
| 23 | SRC_URI[md5sum] = "b06a141cca5cd1a55bbdd25ab833303c" |
| 24 | SRC_URI[sha256sum] = "69d18b7d193f62ca27ed4febcb4c9044aa0c95305d3258fe902e2fae5fc6468d" |
| 25 | |
| 26 | inherit autotools gettext texinfo |
| 27 | |
| 28 | # --with-egd-socket=NAME use NAME for the EGD socket |
| 29 | # --with-photo-viewer=FIXED_VIEWER set a fixed photo ID viewer |
| 30 | # --with-included-zlib use the zlib code included here |
| 31 | # --with-capabilities use linux capabilities default=no |
| 32 | # --with-mailprog=NAME use "NAME -t" for mail transport |
| 33 | # --with-libiconv-prefix[=DIR] search for libiconv in DIR/include and DIR/lib |
| 34 | # --without-libiconv-prefix don't search for libiconv in includedir and libdir |
| 35 | # --with-included-gettext use the GNU gettext library included here |
| 36 | # --with-libintl-prefix[=DIR] search for libintl in DIR/include and DIR/lib |
| 37 | # --without-libintl-prefix don't search for libintl in includedir and libdir |
| 38 | # --without-readline do not support fancy command line editing |
| 39 | # --with-included-regex use the included GNU regex library |
| 40 | # --with-zlib=DIR use libz in DIR |
| 41 | # --with-bzip2=DIR look for bzip2 in DIR |
| 42 | # --enable-static-rnd=egd|unix|linux|auto |
| 43 | # --disable-dev-random disable the use of dev random |
| 44 | # --disable-asm do not use assembler modules |
| 45 | # --enable-m-guard enable memory guard facility |
| 46 | # --enable-selinux-support |
| 47 | # enable SELinux support |
| 48 | # --disable-card-support disable OpenPGP card support |
| 49 | # --disable-gnupg-iconv disable the new iconv code |
| 50 | # --enable-backsigs enable the experimental backsigs code |
| 51 | # --enable-minimal build the smallest gpg binary possible |
| 52 | # --disable-rsa disable the RSA public key algorithm |
| 53 | # --disable-idea disable the IDEA cipher |
| 54 | # --disable-cast5 disable the CAST5 cipher |
| 55 | # --disable-blowfish disable the BLOWFISH cipher |
| 56 | # --disable-aes disable the AES, AES192, and AES256 ciphers |
| 57 | # --disable-twofish disable the TWOFISH cipher |
| 58 | # --disable-sha256 disable the SHA-256 digest |
| 59 | # --disable-sha512 disable the SHA-384 and SHA-512 digests |
| 60 | # --disable-bzip2 disable the BZIP2 compression algorithm |
| 61 | # --disable-exec disable all external program execution |
| 62 | # --disable-photo-viewers disable photo ID viewers |
| 63 | # --disable-keyserver-helpers disable all external keyserver support |
| 64 | # --disable-ldap disable LDAP keyserver interface |
| 65 | # --disable-hkp disable HKP keyserver interface |
| 66 | # --disable-http disable HTTP key fetching interface |
| 67 | # --disable-finger disable Finger key fetching interface |
| 68 | # --disable-mailto disable email keyserver interface |
| 69 | # --disable-keyserver-path disable the exec-path option for keyserver helpers |
| 70 | # --enable-key-cache=SIZE Set key cache to SIZE (default 4096) |
| 71 | # --disable-largefile omit support for large files |
| 72 | # --disable-dns-srv disable the use of DNS SRV in HKP and HTTP |
| 73 | # --disable-nls do not use Native Language Support |
| 74 | # --disable-regex do not handle regular expressions in trust sigs |
| 75 | |
| 76 | EXTRA_OECONF = "--disable-ldap \ |
| 77 | --with-zlib=${STAGING_LIBDIR}/.. \ |
| 78 | --with-bzip2=${STAGING_LIBDIR}/.. \ |
| 79 | --disable-selinux-support \ |
| 80 | --with-readline=${STAGING_LIBDIR}/.. \ |
| 81 | ac_cv_sys_symbol_underscore=no \ |
| 82 | " |
| 83 | |
| 84 | # Force gcc's traditional handling of inline to avoid issues with gcc 5 |
| 85 | CFLAGS += "-fgnu89-inline" |
| 86 | |
| 87 | do_install () { |
| 88 | autotools_do_install |
| 89 | install -d ${D}${docdir}/${BPN} |
| 90 | mv ${D}${datadir}/${BPN}/* ${D}/${docdir}/${BPN}/ || : |
| 91 | mv ${D}${prefix}/doc/* ${D}/${docdir}/${BPN}/ || : |
| 92 | } |
| 93 | |
| 94 | # split out gpgv from main package |
| 95 | RDEPENDS_${PN} = "gpgv" |
| 96 | PACKAGES =+ "gpgv" |
| 97 | FILES_gpgv = "${bindir}/gpgv" |
| 98 | |
| 99 | # Exclude debug files from the main packages |
| 100 | FILES_${PN} = "${bindir}/* ${datadir}/${BPN} ${libexecdir}/${BPN}/*" |
| 101 | FILES_${PN}-dbg += "${libexecdir}/${BPN}/.debug" |
| 102 | |
| 103 | PACKAGECONFIG ??= "" |
| 104 | PACKAGECONFIG[curl] = "--with-libcurl=${STAGING_LIBDIR},--without-libcurl,curl" |
| 105 | PACKAGECONFIG[libusb] = "--with-libusb=${STAGING_LIBDIR},--without-libusb,libusb-compat" |