Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 1 | SECTION = "devel" |
| 2 | SUMMARY = "Light-weight package to set up cgroups at system boot." |
| 3 | DESCRIPTION = "Light-weight package to set up cgroups at system boot." |
| 4 | HOMEPAGE = "http://packages.ubuntu.com/source/precise/cgroup-lite" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=5d5da4e0867cf06014f87102154d0102" |
Patrick Williams | e69d235 | 2017-02-23 20:56:04 -0600 | [diff] [blame^] | 7 | SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+files/cgroup-lite_1.11.tar.xz" |
Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 8 | SRC_URI += "file://cgroups-init" |
Patrick Williams | e69d235 | 2017-02-23 20:56:04 -0600 | [diff] [blame^] | 9 | SRC_URI[md5sum] = "b20976194ee8fdb61e6b55281fb6ead4" |
| 10 | SRC_URI[sha256sum] = "a79ab9ae6fb3ff3ce0aa5539b055c0379eaffdc6c5f003af4010fcea683c1a45" |
Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 11 | |
| 12 | inherit update-rc.d |
| 13 | |
| 14 | INITSCRIPT_NAME = "cgroups-init" |
| 15 | INITSCRIPT_PARAMS = "start 8 2 3 4 5 . stop 20 0 1 6 ." |
| 16 | do_install() { |
| 17 | install -d ${D}/bin |
| 18 | install -d ${D}${sysconfdir}/init.d |
| 19 | install -m 0755 ${S}/scripts/cgroups-mount ${D}/bin |
| 20 | install -m 0755 ${S}/scripts/cgroups-umount ${D}/bin |
| 21 | install -m 0755 ${WORKDIR}/cgroups-init ${D}${sysconfdir}/init.d/cgroups-init |
| 22 | } |