blob: 2a803da521265b66f3f1ca827ca9111b863dedd0 [file] [log] [blame]
Patrick Williamsd849ec72016-08-17 14:59:38 -05001DESCRIPTION = "The Docker toolset to pack, ship, store, and deliver content"
2HOMEPAGE = "https://github.com/docker/distribution"
3SECTION = "devel/go"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
6
7SRCNAME = "distribution"
8
9PKG_NAME = "github.com/docker/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git"
11
12SRCREV = "d957768537c5af40e4f4cd96871f7b2bde9e2923"
13
14S = "${WORKDIR}/git"
15
Patrick Williamse69d2352017-02-23 20:56:04 -060016# NO-OP the do compile rule because this recipe is source only.
17do_compile() {
Patrick Williamsd849ec72016-08-17 14:59:38 -050018}
19
Patrick Williamsd849ec72016-08-17 14:59:38 -050020do_install() {
21 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
Patrick Williamse69d2352017-02-23 20:56:04 -060022 cp -r ${S}/LICENSE ${S}/digest ${D}${prefix}/local/go/src/${PKG_NAME}/
Patrick Williamsd849ec72016-08-17 14:59:38 -050023}
24
25SYSROOT_PREPROCESS_FUNCS += "go_distribution_digeset_sysroot_preprocess"
26
27go_distribution_digeset_sysroot_preprocess () {
28 install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME}
29 cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME})
30}
31
32FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*"