blob: a13aad7788245d0f97bfca378e248ef68f22c1c7 [file] [log] [blame]
Patrick Williams8b8bc412016-08-17 15:02:23 -05001#
2# Need to make this conditional to gstreamer1
3#
4SRC_URI_append_rpi = " \
5 file://0001-config-files-path.patch \
6 file://0002-Don-t-try-to-acquire-buffer-when-src-pad-isn-t-activ.patch \
7 file://0003-fix-decoder-flushing.patch \
8 file://0003-no-timeout-on-get-state.patch \
9 file://0004-Properly-handle-drain-requests-while-flushing.patch \
10 file://0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch \
11"
12
13FILESEXTRAPATHS_prepend := "${THISDIR}/gstreamer1.0-omx:"
14
15GSTREAMER_1_0_OMX_TARGET_rpi = "rpi"
16GSTREAMER_1_0_OMX_CORE_NAME_rpi = "${libdir}/libopenmaxil.so"
17
18
19# How to make this RPI specific?
20EXTRA_OECONF_append_rpi = " CFLAGS="$CFLAGS -I${STAGING_DIR_TARGET}/usr/include/IL -I${STAGING_DIR_TARGET}/usr/include/interface/vcos/pthreads -I${STAGING_DIR_TARGET}/usr/include/interface/vmcs_host/linux""
21#examples only build with GL but not GLES, so disable it for RPI
22EXTRA_OECONF_append_rpi = " --disable-examples"