Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION = "Blueman is a GTK+ Bluetooth Manager" |
| 2 | LICENSE = "GPLv3" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 4 | |
| 5 | DEPENDS = "bluez5 python3-pygobject python3-cython-native python3-setuptools-native intltool-native" |
| 6 | |
| 7 | inherit autotools systemd gsettings python3native gtk-icon-cache |
| 8 | |
| 9 | SRC_URI = " \ |
| 10 | git://github.com/blueman-project/blueman.git \ |
| 11 | file://0001-Search-for-cython3.patch \ |
| 12 | " |
| 13 | SRCREV = "c4a03417e81e21543d4568e8e7f7de307582eb50" |
| 14 | PV = "2.0.5+git${SRCPV}" |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | EXTRA_OECONF = " \ |
| 18 | --disable-runtime-deps-check \ |
| 19 | --disable-schemas-compile \ |
| 20 | " |
| 21 | |
| 22 | SYSTEMD_SERVICE_${PN} = "${BPN}-mechanism.service" |
| 23 | SYSTEMD_AUTO_ENABLE_${PN} = "disable" |
| 24 | |
| 25 | RRECOMENDS_${PN} += "adwaita-icon-theme" |
| 26 | RDEPENDS_${PN} += " \ |
| 27 | python3-dbus \ |
| 28 | packagegroup-tools-bluetooth \ |
| 29 | " |
| 30 | |
| 31 | PACKAGECONFIG[thunar] = "--enable-thunar-sendto,--disable-thunar-sendto,,thunar" |
| 32 | |
| 33 | FILES_${PN} += " \ |
| 34 | ${datadir}/dbus-1 \ |
| 35 | ${datadir}/Thunar \ |
| 36 | ${systemd_user_unitdir} \ |
| 37 | ${exec_prefix}${systemd_system_unitdir} \ |
| 38 | ${PYTHON_SITEPACKAGES_DIR} \ |
| 39 | " |
| 40 | |
| 41 | FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/_blueman.a" |