Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 1 | SUMMARY = "Python interface for libsystemd" |
| 2 | HOMEPAGE = "https://github.com/systemd/python-systemd" |
| 3 | LICENSE = "LGPLv2.1+" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4fbd65380cdd255951079008b364516c" |
| 5 | |
| 6 | PYPI_PACKAGE = "systemd-python" |
| 7 | DEPENDS += "systemd (<=234)" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 8 | RDEPENDS:${PN} += "systemd ${PYTHON_PN}-syslog ${PYTHON_PN}-logging python3-syslog" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 9 | REQUIRED_DISTRO_FEATURES = "systemd" |
| 10 | inherit pypi features_check setuptools3 |
| 11 | |
| 12 | SRC_URI[md5sum] = "5071ea5bcb976186e92a3f5e75df221d" |
| 13 | SRC_URI[sha256sum] = "fd0e44bf70eadae45aadc292cb0a7eb5b0b6372cd1b391228047d33895db83e7" |
| 14 | |
| 15 | # allow for common patches for python- and python3-systemd |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 16 | FILESEXTRAPATHS:prepend := "${THISDIR}/python-systemd:" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 17 | |
| 18 | SRC_URI += "file://endian.patch" |
| 19 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 20 | SRC_URI:append:libc-musl = " file://0001-Provide-implementation-of-strndupa-for-musl.patch" |