Brad Bishop | 83254dc | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor DBUS Object Manager" |
| 2 | DESCRIPTION = "Phosphor DBUS object manager." |
| 3 | HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr" |
| 4 | PR = "r1" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc" |
| 7 | |
Brad Bishop | 83254dc | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 8 | inherit obmc-phosphor-dbus-service |
| 9 | inherit obmc-phosphor-systemd |
| 10 | inherit setuptools |
| 11 | |
Brad Bishop | 8ffb402 | 2016-07-13 17:56:34 -0400 | [diff] [blame] | 12 | DBUS_SERVICE_${PN} += "org.openbmc.ObjectMapper" |
Brad Bishop | 83254dc | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 13 | RDEPENDS_${PN} += " \ |
| 14 | python-xml \ |
| 15 | python-dbus \ |
| 16 | python-pygobject \ |
| 17 | " |
Chris Austen | b70cb7e | 2015-12-02 22:32:06 -0600 | [diff] [blame] | 18 | SRC_URI += "git://github.com/openbmc/phosphor-objmgr" |
Brad Bishop | 83254dc | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 19 | |
Brad Bishop | ea4022a | 2016-07-26 15:52:01 -0400 | [diff] [blame^] | 20 | SRCREV = "22ff24a6e668d00557ef6465f96d664fe33226f3" |
Brad Bishop | 83254dc | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 21 | |
| 22 | S = "${WORKDIR}/git" |
Brad Bishop | ea4022a | 2016-07-26 15:52:01 -0400 | [diff] [blame^] | 23 | |
| 24 | do_compile_append() { |
| 25 | oe_runmake -C libmapper |
| 26 | } |
| 27 | |
| 28 | do_install_append() { |
| 29 | oe_runmake -C libmapper install DESTDIR=${D} |
| 30 | } |
| 31 | |
| 32 | python populate_packages_prepend () { |
| 33 | mapperlibdir = d.getVar("libdir", True) |
| 34 | do_split_packages(d, mapperlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Phosphor mapper %s library', extra_depends='', allow_links=True) |
| 35 | } |
| 36 | PACKAGES_DYNAMIC += "^libmapper.*" |
| 37 | FILES_${PN}_remove = "${libdir}/lib*.so.* ${libdir}/*" |