Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Dependency management tool for Golang" |
| 2 | HOMEPAGE = "https://github.com/golang/dep" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=1bad315647751fab0007812f70d42c0d" |
| 5 | |
| 6 | GO_IMPORT = "github.com/golang/dep" |
| 7 | SRC_URI = "git://${GO_IMPORT} \ |
| 8 | file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \ |
| 9 | " |
| 10 | |
| 11 | # Points to 0.5.0 tag |
| 12 | SRCREV = "224a564abe296670b692fe08bb63a3e4c4ad7978" |
| 13 | |
| 14 | inherit go |
| 15 | |
| 16 | GO_INSTALL = "${GO_IMPORT}/cmd/dep" |
| 17 | |
| 18 | RDEPENDS_${PN}-dev += "bash" |
| 19 | |
| 20 | BBCLASSEXTEND = "native nativesdk" |
| 21 | |
| 22 | # for x86 ends with textrel in ${PN} |
| 23 | # http://errors.yoctoproject.org/Errors/Details/185630/ |
| 24 | # ERROR: QA Issue: ELF binary '/work/i586-oe-linux/go-dep/0.4.1-r0/packages-split/go-dep/usr/bin/dep' has relocations in .text [textrel] |
| 25 | INSANE_SKIP_${PN} += "textrel" |
| 26 | |
| 27 | # for aarch64 ends with textrel in ${PN}-ptest |
| 28 | # http://errors.yoctoproject.org/Errors/Details/185632/ |
| 29 | # ERROR: QA Issue: ELF binary '/work/aarch64-oe-linux/go-dep/0.4.1-r0/packages-split/go-dep-ptest/usr/lib/go-dep/ptest/github.com/golang/dep/cmd/dep/dep.test' has relocations in .text [textrel] |
| 30 | INSANE_SKIP_${PN}-ptest += "textrel" |
| 31 | |
| 32 | # For compiling ptest on mips and mips64, the current go-dep version fails with the go 1.11 toolchain. |
| 33 | # error message: vet config not found |
| 34 | PTEST_ENABLED_mips = "0" |
| 35 | PTEST_ENABLED_mips64 = "0" |