Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | DESCRIPTION = "pytest plugin for generating html reports from test results" |
Andrew Geissler | eafcbb8 | 2020-06-05 17:59:17 -0500 | [diff] [blame^] | 2 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" |
| 3 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 4 | LICENSE = "MPL-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://../pytest-html.LICENSE;md5=5d425c8f3157dbf212db2ec53d9e5132" |
| 6 | |
| 7 | # Per README.rst the license statement is fetched from |
| 8 | # https://raw.githubusercontent.com/davehunt/pytest-html/master/LICENSE |
| 9 | SRC_URI += "https://raw.githubusercontent.com/davehunt/pytest-html/master/LICENSE;name=license;downloadfilename=pytest-html.LICENSE" |
Andrew Geissler | eafcbb8 | 2020-06-05 17:59:17 -0500 | [diff] [blame^] | 10 | SRC_URI[license.md5sum] = "5d425c8f3157dbf212db2ec53d9e5132" |
| 11 | SRC_URI[license.sha256sum] = "2bfdca60adf803108d4c7f009000bea76ad00e621e163197881b0eaae91b530e" |
| 12 | |
| 13 | SRC_URI[sha256sum] = "6a4ac391e105e391208e3eb9bd294a60dd336447fd8e1acddff3a6de7f4e57c5" |
| 14 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | |
| 16 | PYPI_PACKAGE = "pytest-html" |
| 17 | |
| 18 | inherit pypi setuptools3 |
| 19 | |
Andrew Geissler | eafcbb8 | 2020-06-05 17:59:17 -0500 | [diff] [blame^] | 20 | RDEPENDS_${PN} += " \ |
| 21 | ${PYTHON_PN}-pytest \ |
| 22 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | |
Andrew Geissler | eafcbb8 | 2020-06-05 17:59:17 -0500 | [diff] [blame^] | 24 | BBCLASSEXTEND = "native nativesdk" |