blob: 27b768155e1b79ce4c15b64faff243c7fdacefa8 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "pytest plugin for generating html reports from test results"
Andrew Geisslereafcbb82020-06-05 17:59:17 -05002DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
3
Andrew Geissler82c905d2020-04-13 13:39:40 -05004LICENSE = "MPL-2.0"
5LIC_FILES_CHKSUM = "file://../pytest-html.LICENSE;md5=5d425c8f3157dbf212db2ec53d9e5132"
6
7# Per README.rst the license statement is fetched from
8# https://raw.githubusercontent.com/davehunt/pytest-html/master/LICENSE
9SRC_URI += "https://raw.githubusercontent.com/davehunt/pytest-html/master/LICENSE;name=license;downloadfilename=pytest-html.LICENSE"
Andrew Geisslereafcbb82020-06-05 17:59:17 -050010SRC_URI[license.md5sum] = "5d425c8f3157dbf212db2ec53d9e5132"
11SRC_URI[license.sha256sum] = "2bfdca60adf803108d4c7f009000bea76ad00e621e163197881b0eaae91b530e"
12
13SRC_URI[sha256sum] = "6a4ac391e105e391208e3eb9bd294a60dd336447fd8e1acddff3a6de7f4e57c5"
14
Andrew Geissler82c905d2020-04-13 13:39:40 -050015
16PYPI_PACKAGE = "pytest-html"
17
18inherit pypi setuptools3
19
Andrew Geisslereafcbb82020-06-05 17:59:17 -050020RDEPENDS_${PN} += " \
21 ${PYTHON_PN}-pytest \
22"
Andrew Geissler82c905d2020-04-13 13:39:40 -050023
Andrew Geisslereafcbb82020-06-05 17:59:17 -050024BBCLASSEXTEND = "native nativesdk"