Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | require libtool-${PV}.inc |
| 2 | |
| 3 | FILESEXTRAPATHS =. "${FILE_DIRNAME}/libtool:" |
| 4 | |
| 5 | SRC_URI += "file://prefix.patch" |
| 6 | SRC_URI += "file://fixinstall.patch" |
| 7 | |
| 8 | inherit nativesdk |
| 9 | |
| 10 | S = "${WORKDIR}/libtool-${PV}" |
| 11 | FILES_${PN} += "${datadir}/libtool/*" |
| 12 | |
| 13 | do_configure_prepend () { |
| 14 | # Remove any existing libtool m4 since old stale versions would break |
| 15 | # any upgrade |
| 16 | rm -f ${STAGING_DATADIR}/aclocal/libtool.m4 |
| 17 | rm -f ${STAGING_DATADIR}/aclocal/lt*.m4 |
| 18 | } |
| 19 | |
| 20 | do_install () { |
| 21 | autotools_do_install |
| 22 | install -d ${D}${bindir}/ |
| 23 | install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/ |
| 24 | } |
| 25 | |
| 26 | SYSROOT_PREPROCESS_FUNCS += "libtoolnativesdk_sysroot_preprocess" |
| 27 | |
| 28 | libtoolnativesdk_sysroot_preprocess () { |
| 29 | install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/ |
| 30 | install -m 755 ${D}${bindir}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${bindir_crossscripts}/${HOST_SYS}-libtool |
| 31 | } |