Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "ICE: Inter-Client Exchange library" |
| 2 | |
| 3 | DESCRIPTION = "The Inter-Client Exchange (ICE) protocol provides a \ |
| 4 | generic framework for building protocols on top of reliable, byte-stream \ |
| 5 | transport connections. It provides basic mechanisms for setting up and \ |
| 6 | shutting down connections, for performing authentication, for \ |
| 7 | negotiating versions, and for reporting errors. " |
| 8 | |
| 9 | require xorg-lib-common.inc |
| 10 | |
| 11 | LICENSE = "MIT-style" |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=d162b1b3c6fa812da9d804dcf8584a93" |
| 13 | |
| 14 | DEPENDS += "xproto xtrans" |
| 15 | PROVIDES = "ice" |
| 16 | |
| 17 | PE = "1" |
| 18 | |
| 19 | XORG_PN = "libICE" |
| 20 | |
| 21 | BBCLASSEXTEND = "native" |
| 22 | |
| 23 | SRC_URI[md5sum] = "addfb1e897ca8079531669c7c7711726" |
| 24 | SRC_URI[sha256sum] = "8f7032f2c1c64352b5423f6b48a8ebdc339cc63064af34d66a6c9aa79759e202" |
| 25 | |
Brad Bishop | bba38f3 | 2018-08-23 16:11:46 +0800 | [diff] [blame] | 26 | SRC_URI += "file://CVE-2017-2626.patch" |
| 27 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 28 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 29 | PACKAGECONFIG[arc4] = "ac_cv_lib_bsd_arc4random_buf=yes,ac_cv_lib_bsd_arc4random_buf=no,libbsd" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 30 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |