Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Key/value database library with extensible hashing" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/gdbm/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "GPLv3" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=241da1b9fe42e642cbb2c24d5e0c4d24" |
| 6 | |
| 7 | |
| 8 | SRC_URI = "${GNU_MIRROR}/gdbm/gdbm-${PV}.tar.gz \ |
| 9 | file://run-ptest \ |
| 10 | file://ptest.patch \ |
| 11 | " |
| 12 | |
| 13 | SRC_URI[md5sum] = "c2ddcb3897efa0f57484af2bd4f4f848" |
| 14 | SRC_URI[sha256sum] = "cdceff00ffe014495bed3aed71c7910aa88bf29379f795abc0f46d4ee5f8bc5f" |
| 15 | |
| 16 | inherit autotools gettext texinfo lib_package ptest |
| 17 | |
| 18 | # Needed for dbm python module |
| 19 | EXTRA_OECONF = "-enable-libgdbm-compat" |
| 20 | |
| 21 | # Stop presence of dbm/nbdm on the host contaminating builds |
| 22 | CACHED_CONFIGUREVARS += "ac_cv_lib_ndbm_main=no ac_cv_lib_dbm_main=no" |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |
| 25 | |
| 26 | do_install_append () { |
| 27 | # Create a symlink to ndbm.h and gdbm.h in include/gdbm to let other packages to find |
| 28 | # these headers |
| 29 | install -d ${D}${includedir}/gdbm |
| 30 | ln -sf ../ndbm.h ${D}/${includedir}/gdbm/ndbm.h |
| 31 | ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h |
| 32 | } |
| 33 | |
| 34 | RDEPENDS_${PN}-ptest += "diffutils" |
| 35 | |
| 36 | do_compile_ptest() { |
| 37 | oe_runmake -C tests buildtests |
| 38 | } |
| 39 | |
| 40 | PACKAGES =+ "${PN}-compat \ |
| 41 | " |
| 42 | FILES_${PN}-compat = "${libdir}/libgdbm_compat${SOLIBS} \ |
| 43 | " |