Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "7-zip is a commandline utility handling 7z archives." |
| 2 | HOMEPAGE = "http://www.7-zip.org/" |
| 3 | LICENSE = "LGPL-2.1+ & unRAR" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://DOC/copying.txt;md5=4fbd65380cdd255951079008b364516c \ |
| 5 | file://DOC/unRarLicense.txt;md5=9c87ddde469ef94aed153b0951d088de \ |
| 6 | file://DOC/License.txt;md5=879598edf1f54dddb6930d7581357f8b" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 7 | |
| 8 | SRC_URI = "http://downloads.sourceforge.net/p7zip/p7zip/${PV}/p7zip_${PV}_src_all.tar.bz2 \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 9 | file://do_not_override_compiler_and_do_not_strip.patch \ |
| 10 | file://CVE-2017-17969.patch \ |
| 11 | file://0001-Fix-narrowing-errors-Wc-11-narrowing.patch \ |
| 12 | " |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 13 | |
| 14 | SRC_URI[md5sum] = "a0128d661cfe7cc8c121e73519c54fbf" |
| 15 | SRC_URI[sha256sum] = "5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6e2341f" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 16 | |
| 17 | S = "${WORKDIR}/${BPN}_${PV}" |
| 18 | |
| 19 | do_install() { |
| 20 | install -d ${D}${bindir} |
| 21 | install -m 0755 ${S}/bin/* ${D}${bindir} |
| 22 | } |
| 23 | |
| 24 | # all3: to build bin/7za, bin/7z (with its plugins), bin/7zr and bin/7zCon.sfx |
| 25 | EXTRA_OEMAKE_class-native = "all3" |
| 26 | |
| 27 | do_install_class-native() { |
| 28 | install -d ${D}${bindir} |
| 29 | install -d ${D}${bindir}/Codecs |
| 30 | install -m 0755 ${S}/bin/7* ${D}${bindir} |
| 31 | install -m 0755 ${S}/bin/Codecs/* ${D}${bindir}/Codecs |
| 32 | |
| 33 | # Create a shell script wrapper to execute next to 7z.so |
| 34 | mv ${D}${bindir}/7z ${D}${bindir}/7z.bin |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 35 | cat > ${D}${bindir}/7z << 'EOF' |
| 36 | #!/bin/sh |
| 37 | exec "$(dirname "$0")"/7z.bin "$@" |
| 38 | EOF |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 39 | chmod 0755 ${D}${bindir}/7z |
| 40 | } |
| 41 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 42 | BBCLASSEXTEND = "native" |