Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "C bindings for apps which will manipulate JSON data" |
| 2 | DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C." |
| 3 | HOMEPAGE = "https://github.com/json-c/json-c/wiki" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2" |
| 6 | |
| 7 | SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz" |
| 8 | SRC_URI[md5sum] = "04969ad59cc37bddd83741a08b98f350" |
| 9 | SRC_URI[sha256sum] = "b87e608d4d3f7bfdd36ef78d56d53c74e66ab278d318b71e6002a369d36f4873" |
| 10 | |
| 11 | UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+).tar" |
| 12 | # json-c releases page is fetching the list of releases in some weird XML format |
| 13 | # from https://s3.amazonaws.com/json-c_releases and processes it with javascript :-/ |
| 14 | #UPSTREAM_CHECK_URI = "https://s3.amazonaws.com/json-c_releases/releases/index.html" |
| 15 | RECIPE_UPSTREAM_VERSION = "0.13.1" |
| 16 | RECIPE_UPSTREAM_DATE = "Mar 04, 2018" |
| 17 | CHECK_DATE = "May 02, 2018" |
| 18 | |
| 19 | RPROVIDES_${PN} = "libjson" |
| 20 | |
| 21 | inherit autotools |
| 22 | |
| 23 | EXTRA_OECONF = "--enable-rdrand" |
| 24 | |
| 25 | do_configure_prepend() { |
| 26 | # Clean up autoconf cruft that should not be in the tarball |
| 27 | rm -f ${S}/config.status |
| 28 | } |
| 29 | |
| 30 | BBCLASSEXTEND = "native nativesdk" |