Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Python GObject bindings" |
| 2 | SECTION = "devel/python" |
| 3 | LICENSE = "LGPLv2.1" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7" |
| 5 | |
| 6 | inherit gnomebase distutils3-base gobject-introspection upstream-version-is-even |
| 7 | |
| 8 | DEPENDS += "python3 glib-2.0" |
| 9 | |
| 10 | SRCNAME="pygobject" |
| 11 | SRC_URI = " \ |
| 12 | http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \ |
| 13 | " |
| 14 | |
| 15 | SRC_URI[md5sum] = "3bac63c86bb963aa401f97859464aa90" |
| 16 | SRC_URI[sha256sum] = "3dd3e21015d06e00482ea665fc1733b77e754a6ab656a5db5d7f7bfaf31ad0b0" |
| 17 | |
| 18 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 19 | |
| 20 | PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}" |
| 21 | |
| 22 | # python3-pycairo is checked on configuration -> DEPENDS |
| 23 | # we don't link against python3-pycairo -> RDEPENDS |
| 24 | PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo python3-pycairo, python3-pycairo" |
| 25 | |
| 26 | RDEPENDS_${PN} += "python3-setuptools" |
| 27 | |
| 28 | BBCLASSEXTEND = "native" |
| 29 | PACKAGECONFIG_class-native = "" |