Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "A parallel implementation of gzip" |
| 2 | DESCRIPTION = "pigz, which stands for parallel implementation of gzip, is a \ |
| 3 | fully functional replacement for gzip that exploits multiple processors and \ |
| 4 | multiple cores to the hilt when compressing data. pigz was written by Mark \ |
| 5 | Adler, and uses the zlib and pthread libraries." |
| 6 | HOMEPAGE = "http://zlib.net/pigz/" |
| 7 | SECTION = "console/utils" |
| 8 | LICENSE = "Zlib & Apache-2.0" |
| 9 | LIC_FILES_CHKSUM = "file://pigz.c;md5=9ae6dee8ceba9610596ed0ada493d142;beginline=7;endline=21" |
| 10 | |
| 11 | SRC_URI = "http://zlib.net/${BPN}/fossils/${BP}.tar.gz" |
| 12 | SRC_URI[md5sum] = "def2f6e19d9d8231445adc1349d346df" |
| 13 | SRC_URI[sha256sum] = "a4f816222a7b4269bd232680590b579ccc72591f1bb5adafcd7208ca77e14f73" |
| 14 | # Point this at the homepage in case /fossils/ isn't updated |
| 15 | UPSTREAM_CHECK_URI = "http://zlib.net/${BPN}/" |
| 16 | UPSTREAM_CHECK_REGEX = "pigz-(?P<pver>.*)\.tar" |
| 17 | |
| 18 | DEPENDS = "zlib" |
| 19 | |
| 20 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| 21 | |
| 22 | do_install() { |
| 23 | # Install files into /bin (FHS), which is typical place for gzip |
| 24 | install -d ${D}${base_bindir} |
| 25 | install ${B}/pigz ${D}${base_bindir}/pigz |
| 26 | ln -nsf pigz ${D}${base_bindir}/unpigz |
| 27 | ln -nsf pigz ${D}${base_bindir}/pigzcat |
| 28 | } |
| 29 | |
| 30 | BBCLASSEXTEND = "native nativesdk" |