Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | require boost-${PV}.inc |
2 | |||||
3 | SUMMARY = "Portable Boost.Jam build tool for boost" | ||||
4 | SECTION = "devel" | ||||
5 | |||||
6 | inherit native | ||||
7 | |||||
8 | SRC_URI += "file://bjam-native-build-bjam.debug.patch \ | ||||
9 | " | ||||
10 | |||||
11 | do_compile() { | ||||
12 | ./bootstrap.sh --with-toolset=gcc | ||||
13 | } | ||||
14 | |||||
15 | do_install() { | ||||
16 | install -d ${D}${bindir}/ | ||||
17 | # install unstripped version for bjam | ||||
18 | install -c -m 755 bjam.debug ${D}${bindir}/bjam | ||||
19 | } |