Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Provides a way to load and enumerate PKCS#11 modules" |
| 2 | LICENSE = "BSD" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=02933887f609807fbb57aa4237d14a50" |
| 4 | |
| 5 | inherit autotools gettext pkgconfig gtk-doc |
| 6 | |
| 7 | DEPENDS = "libtasn1 libffi" |
| 8 | |
| 9 | SRC_URI = "git://github.com/p11-glue/p11-kit \ |
| 10 | file://0001-LINGUAS-drop-the-languages-for-which-upstream-does-n.patch \ |
| 11 | " |
| 12 | SRCREV = "3770793f026e46a000d2d8816d56122598289d5c" |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | AUTOTOOLS_AUXDIR = "${S}/build/litter" |
| 16 | |
| 17 | PACKAGECONFIG ??= "" |
| 18 | PACKAGECONFIG[trust-paths] = "--with-trust-paths=/etc/ssl/certs/ca-certificates.crt,--without-trust-paths,,ca-certificates" |
| 19 | |
| 20 | # This recipe does not use the standard gtk-doc m4 macros, and so the ./configure flags |
| 21 | # that control gtk-doc build are non-standard |
| 22 | EXTRA_OECONF_prepend_class-target = "${@bb.utils.contains('GTKDOC_ENABLED', 'True', '--enable-doc --enable-doc-html --disable-doc-pdf', \ |
| 23 | '--disable-doc', d)} " |
| 24 | |
| 25 | # When building native recipes, disable gtkdoc, as it is not necessary, |
| 26 | # pulls in additional dependencies, and makes build times longer |
| 27 | EXTRA_OECONF_prepend_class-native = "--disable-doc " |
| 28 | EXTRA_OECONF_prepend_class-nativesdk = "--disable-doc " |
| 29 | |
| 30 | UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-gtk-doc-html --disable-gtk-doc-pdf --enable-gtk-doc --disable-gtk-doc" |
| 31 | |
| 32 | # p11-kit relies on these two being copied from source tree |
| 33 | # instead of being regenerated by gtkdoc-scan, but doesn't setup |
| 34 | # dependencies correctly when there is a parallel build. Let's pre-copy |
| 35 | # them instead. |
| 36 | do_compile_prepend () { |
| 37 | cp ${S}/doc/manual/p11-kit-overrides.txt ${S}/doc/manual/p11-kit-sections.txt ${B}/doc/manual/ |
| 38 | } |
| 39 | |
| 40 | FILES_${PN} += " \ |
| 41 | ${libdir}/p11-kit-proxy.so \ |
| 42 | ${libdir}/pkcs11/*.so \ |
| 43 | ${libdir}/pkcs11/*.la" |
| 44 | |
| 45 | # PN contains p11-kit-proxy.so, a symlink to a loadable module |
| 46 | INSANE_SKIP_${PN} = "dev-so" |