Andrew Geissler | 706d5aa | 2021-02-12 15:55:30 -0600 | [diff] [blame] | 1 | SUMMARY = "a fast C/C++ compiler cache" |
| 2 | DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \ |
| 3 | by caching the result of previous compilations and detecting when the \ |
| 4 | same compilation is being done again. Supported languages are C, C\+\+, \ |
| 5 | Objective-C and Objective-C++." |
| 6 | HOMEPAGE = "http://ccache.samba.org" |
| 7 | SECTION = "devel" |
| 8 | |
| 9 | LICENSE = "GPLv3+" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=22d514dbc01fdf9a9784334b6b59417a" |
| 11 | |
| 12 | DEPENDS = "zlib" |
| 13 | |
| 14 | SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz" |
| 15 | SRC_URI[sha256sum] = "34309a59d4b6b6b33756366aa9d3144a4655587be9f914476b4c0e2d36365f01" |
| 16 | |
| 17 | UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/" |
| 18 | |
| 19 | inherit autotools |
| 20 | |
| 21 | # Remove ccache-native's dependencies, so that it can be used widely by |
| 22 | # other native recipes. |
| 23 | DEPENDS_class-native = "" |
| 24 | EXTRA_OECONF_class-native = "--with-bundled-zlib" |
| 25 | INHIBIT_AUTOTOOLS_DEPS_class-native = "1" |
| 26 | PATCHTOOL = "patch" |
| 27 | |
| 28 | BBCLASSEXTEND = "native" |
| 29 | |
| 30 | do_configure_class-native() { |
| 31 | oe_runconf |
| 32 | } |