Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Opus Audio Codec" |
| 2 | DESCRIPTION = "The Opus codec is designed for interactive \ |
| 3 | speech and audio transmission over the Internet. It is \ |
| 4 | designed by the IETF Codec Working Group and incorporates \ |
| 5 | technology from Skype's SILK codec and Xiph.Org's CELT codec." |
| 6 | HOMEPAGE = "http://www.opus-codec.org/" |
| 7 | SECTION = "libs/multimedia" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 8 | LICENSE = "BSD-3-Clause" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=e304cdf74c2a1b0a33a5084c128a23a3" |
| 10 | |
| 11 | SRC_URI = "http://downloads.xiph.org/releases/opus/opus-${PV}.tar.gz" |
Brad Bishop | 7e36d53 | 2019-09-16 07:44:26 -0400 | [diff] [blame] | 12 | SRC_URI[md5sum] = "d7c07db796d21c9cf1861e0c2b0c0617" |
| 13 | SRC_URI[sha256sum] = "65b58e1e25b2a114157014736a3d9dfeaad8d41be1c8179866f144a2fb44ff9d" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/opus-${PV}" |
| 16 | |
| 17 | inherit autotools pkgconfig |
| 18 | |
| 19 | PACKAGECONFIG ??= "" |
| 20 | PACKAGECONFIG[fixed-point] = "--enable-fixed-point,," |
| 21 | PACKAGECONFIG[float-approx] = "--enable-float-approx,," |
| 22 | |
| 23 | EXTRA_OECONF = " \ |
| 24 | --with-NE10-includes=${STAGING_DIR_TARGET}${includedir} \ |
| 25 | --with-NE10-libraries=${STAGING_DIR_TARGET}${libdir} \ |
| 26 | --enable-asm \ |
| 27 | --enable-intrinsics \ |
| 28 | --enable-custom-modes \ |
| 29 | " |
| 30 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 31 | # ne10 is available only for armv7a, armv7ve and aarch64 |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 32 | DEPENDS_append_aarch64 = " ne10" |
| 33 | DEPENDS_append_armv7a = " ne10" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 34 | DEPENDS_append_armv7ve = " ne10" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 35 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 36 | python () { |
| 37 | if d.getVar('TARGET_FPU') in [ 'soft' ]: |
| 38 | d.appendVar('PACKAGECONFIG', ' fixed-point') |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 39 | } |
| 40 | |
| 41 | # Fails to build with thumb-1 (qemuarm) |
| 42 | #| {standard input}: Assembler messages: |
| 43 | #| {standard input}:389: Error: selected processor does not support Thumb mode `smull r5,r7,r1,r4' |
| 44 | #| {standard input}:418: Error: selected processor does not support Thumb mode `smull r5,r6,r4,r1' |
| 45 | #| {standard input}:448: Error: selected processor does not support Thumb mode `smull r4,r5,r1,r0' |
| 46 | #| {standard input}:474: Error: selected processor does not support Thumb mode `smull r0,r4,r8,r1' |
| 47 | #| {standard input}:510: Error: selected processor does not support Thumb mode `smull fp,r0,r10,r1' |
| 48 | #| {standard input}:553: Error: selected processor does not support Thumb mode `smull fp,r1,r10,r3' |
| 49 | #| {standard input}:741: Error: selected processor does not support Thumb mode `smull r3,r0,r6,r10' |
| 50 | #| {standard input}:761: Error: selected processor does not support Thumb mode `smull fp,r2,r3,r9' |
| 51 | #| {standard input}:773: Error: selected processor does not support Thumb mode `smull fp,r3,r5,r8' |
| 52 | #| make[2]: *** [celt/celt.lo] Error 1 |
Brad Bishop | 90ca747 | 2019-08-20 09:15:15 -0400 | [diff] [blame] | 53 | ARM_INSTRUCTION_SET_armv5 = "arm" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 54 | |
| 55 | BBCLASSEXTEND = "native nativesdk" |