Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 1 | SUMMARY = "A library for property-based testing" |
| 2 | HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python" |
| 3 | LICENSE = "MPL-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c" |
| 5 | |
| 6 | PYPI_PACKAGE = "hypothesis" |
| 7 | |
| 8 | inherit pypi setuptools3 |
| 9 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 10 | SRC_URI[sha256sum] = "0563b9711fd9bf478cb591580a575c369d2c396f283efa85d0f9a75b26db65b5" |
Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 11 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 12 | RDEPENDS:${PN} += " \ |
Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 13 | python3-attrs \ |
| 14 | python3-compression \ |
| 15 | python3-core \ |
| 16 | python3-json \ |
| 17 | python3-sortedcontainers \ |
| 18 | python3-statistics \ |
| 19 | python3-unittest \ |
| 20 | " |
| 21 | |
| 22 | BBCLASSEXTEND = "native nativesdk" |