Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 1 | HOMEPAGE = "http://github.com/openbmc/google-ipmi-sys" |
| 2 | SUMMARY = "Google Sys OEM commands" |
Patrick Venture | edb6192 | 2018-09-21 14:57:58 -0700 | [diff] [blame^] | 3 | DESCRIPTION = "Google Sys OEM commands" |
Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 4 | |
| 5 | inherit autotools pkgconfig |
Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 6 | inherit systemd |
| 7 | inherit obmc-phosphor-ipmiprovider-symlink |
| 8 | |
Patrick Venture | edb6192 | 2018-09-21 14:57:58 -0700 | [diff] [blame^] | 9 | LICENSE = "Apache-2.0" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 11 | |
Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 12 | DEPENDS += "autoconf-archive-native" |
| 13 | DEPENDS += "sdbusplus" |
| 14 | DEPENDS += "phosphor-logging" |
Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 15 | DEPENDS += "phosphor-ipmi-host" |
| 16 | |
Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 17 | S = "${WORKDIR}/git" |
| 18 | SRC_URI = "git://github.com/openbmc/google-ipmi-sys" |
Patrick Venture | edb6192 | 2018-09-21 14:57:58 -0700 | [diff] [blame^] | 19 | SRCREV = "ef45005c2c441a89a9bd84b9b0f22ac8a2fd9b65" |
Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 20 | |
| 21 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 22 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 23 | FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| 24 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
| 25 | |
| 26 | HOSTIPMI_PROVIDER_LIBRARY += "libsyscmds.so" |
| 27 | |
| 28 | SYSTEMD_PACKAGES = "${PN}" |
| 29 | SYSTEMD_SERVICE_${PN} = "gbmc-psu-hardreset.target" |
| 30 | |
| 31 | do_install_append() { |
| 32 | install -d ${D}${systemd_system_unitdir} |
| 33 | install -m 0644 ${S}/gbmc-psu-hardreset.target ${D}${systemd_system_unitdir} |
| 34 | } |