Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenSAF is an open source implementation of the SAF AIS specification" |
| 2 | DESCRIPTION = "OpenSAF is an open source project established to develop a base platform \ |
| 3 | middleware consistent with Service Availability Forum (SA Forum) \ |
| 4 | specifications, under the LGPLv2.1 license. The OpenSAF Foundation was \ |
| 5 | established by leading Communications and Enterprise Computing Companies to \ |
| 6 | facilitate the OpenSAF Project and to accelerate the adoption of the OpenSAF \ |
| 7 | code base in commercial products. \ |
| 8 | The OpenSAF project was launched in mid 2007 and has been under development by \ |
| 9 | an informal group of supporters of the OpenSAF initiative. The OpenSAF \ |
| 10 | Foundation was founded on January 22nd 2008 with Emerson Network Power, \ |
| 11 | Ericsson, Nokia Siemens Networks, HP and Sun Microsystems as founding members." |
| 12 | HOMEPAGE = "http://www.opensaf.org" |
| 13 | SECTION = "admin" |
| 14 | LICENSE = "LGPLv2.1" |
| 15 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7" |
| 16 | |
| 17 | DEPENDS = "libxml2 python" |
| 18 | TOOLCHAIN = "gcc" |
| 19 | |
| 20 | SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}" |
| 21 | |
| 22 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \ |
| 23 | file://0001-configure-Pass-linker-specific-options-with-Wl.patch \ |
| 24 | file://0001-configure-Disable-format-overflow-if-supported-by-gc.patch \ |
| 25 | file://0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch \ |
| 26 | file://0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch \ |
| 27 | " |
| 28 | SRC_URI[md5sum] = "42064f5ddbc7f560bfc5ff93ea9eecc7" |
| 29 | SRC_URI[sha256sum] = "f9e24897f9cfd63bb3115f6275c706de1702d3d9bae2fc423227db72b23c37f0" |
| 30 | |
| 31 | inherit autotools useradd systemd pkgconfig |
| 32 | |
| 33 | USERADD_PACKAGES = "${PN}" |
| 34 | GROUPADD_PARAM_${PN} = "-f -r opensaf" |
| 35 | USERADD_PARAM_${PN} = "-r -g opensaf -d ${datadir}/opensaf/ -s ${sbindir}/nologin -c \"OpenSAF\" opensaf" |
| 36 | |
| 37 | SYSTEMD_SERVICE_${PN} += "opensafd.service" |
| 38 | SYSTEMD_AUTO_ENABLE = "disable" |
| 39 | |
| 40 | PACKAGECONFIG[systemd] = ",,systemd" |
| 41 | PACKAGECONFIG[openhpi] = "--with-hpi-interface=B03 --enable-ais-plm,,openhpi" |
| 42 | |
| 43 | PACKAGECONFIG_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" |
| 44 | |
| 45 | PKGLIBDIR="${libdir}" |
| 46 | |
| 47 | LDFLAGS += "-Wl,--as-needed -latomic -Wl,--no-as-needed" |
| 48 | |
| 49 | do_install_append() { |
| 50 | cp -av --no-preserve=ownership ${B}/lib/.libs/*.so* ${D}${libdir} |
| 51 | rm -fr "${D}${localstatedir}/lock" |
| 52 | rm -fr "${D}${localstatedir}/run" |
| 53 | rmdir --ignore-fail-on-non-empty "${D}${localstatedir}" |
| 54 | rmdir --ignore-fail-on-non-empty "${D}${datadir}/java" |
| 55 | if [ ! -d "${D}${sysconfdir}/init.d" ]; then |
| 56 | install -d ${D}${sysconfdir}/init.d |
| 57 | install -m 0755 ${B}/osaf/services/infrastructure/nid/scripts/opensafd ${D}${sysconfdir}/init.d/ |
| 58 | fi |
| 59 | } |
| 60 | |
| 61 | FILES_${PN} += "${systemd_unitdir}/system/*.service" |
| 62 | FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a" |
| 63 | |
| 64 | INSANE_SKIP_${PN} = "dev-so" |
| 65 | |
| 66 | RDEPENDS_${PN} += "bash python" |
| 67 | |