Marri Devender Rao | 84f125e | 2017-04-27 03:38:39 -0500 | [diff] [blame] | 1 | SUMMARY = "OpenPOWER Debug Collector" |
Vishwanatha Subbanna | eeae33c | 2017-06-13 15:00:24 +0530 | [diff] [blame] | 2 | DESCRIPTION = "Application to log error during host checkstop and watchdog timeout" |
Marri Devender Rao | 84f125e | 2017-04-27 03:38:39 -0500 | [diff] [blame] | 3 | |
| 4 | PR = "r1" |
Patrick Venture | e2e5fa7 | 2018-10-26 09:43:44 -0700 | [diff] [blame] | 5 | PV = "1.0+git${SRCPV}" |
Marri Devender Rao | 84f125e | 2017-04-27 03:38:39 -0500 | [diff] [blame] | 6 | |
| 7 | inherit autotools \ |
| 8 | pkgconfig \ |
| 9 | obmc-phosphor-systemd \ |
Jayanth Othayoth | 9b2384a | 2020-02-20 00:13:48 -0600 | [diff] [blame] | 10 | python3native \ |
Marri Devender Rao | db5a6c4 | 2017-09-27 21:55:57 -0500 | [diff] [blame] | 11 | phosphor-dbus-yaml |
Marri Devender Rao | 84f125e | 2017-04-27 03:38:39 -0500 | [diff] [blame] | 12 | |
Patrick Williams | 6c9e014 | 2020-04-03 15:45:27 -0500 | [diff] [blame] | 13 | require ${BPN}.inc |
Andrew Geissler | ee12600 | 2021-02-01 16:17:23 -0600 | [diff] [blame^] | 14 | require ${BPN}-systemd-links.inc |
Marri Devender Rao | 84f125e | 2017-04-27 03:38:39 -0500 | [diff] [blame] | 15 | |
| 16 | DEPENDS += " \ |
| 17 | phosphor-logging \ |
| 18 | autoconf-archive-native \ |
Patrick Williams | ba5282b | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 19 | ${PYTHON_PN}-sdbus++-native \ |
Marri Devender Rao | 84f125e | 2017-04-27 03:38:39 -0500 | [diff] [blame] | 20 | " |
Marri Devender Rao | 84f125e | 2017-04-27 03:38:39 -0500 | [diff] [blame] | 21 | S = "${WORKDIR}/git" |
| 22 | |
Vishwanatha Subbanna | b7f7419 | 2017-06-13 14:11:06 +0530 | [diff] [blame] | 23 | # This provides below 2 applications that are called into in case |
| 24 | # of host checkstop and host watchdog timeout respectively. |
| 25 | APPS = "checkstop watchdog" |
Marri Devender Rao | 84f125e | 2017-04-27 03:38:39 -0500 | [diff] [blame] | 26 | |
Vishwanatha Subbanna | b7f7419 | 2017-06-13 14:11:06 +0530 | [diff] [blame] | 27 | DEBUG_TMPL = "openpower-debug-collector-{0}@.service" |
| 28 | SYSTEMD_SERVICE_${PN} += "${@compose_list(d, 'DEBUG_TMPL', 'APPS')}" |
| 29 | |
Marri Devender Rao | db5a6c4 | 2017-09-27 21:55:57 -0500 | [diff] [blame] | 30 | |
| 31 | # Do not depend on phosphor-logging for native build |
| 32 | DEPENDS_remove_class-native = "phosphor-logging" |
| 33 | |
| 34 | # Do not depend on phosphor-logging for native SDK build |
| 35 | DEPENDS_remove_class-nativesdk = "phosphor-logging" |
| 36 | |
| 37 | # Provide a means to enable/disable install_error_yaml feature |
| 38 | PACKAGECONFIG ??= "install_error_yaml" |
| 39 | PACKAGECONFIG[install_error_yaml] = " \ |
| 40 | --enable-install_error_yaml, \ |
| 41 | --disable-install_error_yaml, ,\ |
| 42 | " |
| 43 | |
| 44 | # Enable install_error_yaml during native and native SDK build |
| 45 | PACKAGECONFIG_add_class-native = "install_error_yaml" |
| 46 | PACKAGECONFIG_add_class-nativesdk = "install_error_yaml" |
| 47 | |
| 48 | # Disable install_error_yaml during target build |
| 49 | PACKAGECONFIG_remove_class-target = "install_error_yaml" |
| 50 | |
| 51 | # Disable generating elog error header file during bitbake. Applications |
| 52 | # should be using the elog header generated by phosphor-logging recipe |
| 53 | EXTRA_OECONF += "--disable-gen_errors" |
| 54 | |
| 55 | BBCLASSEXTEND += "native nativesdk" |