Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Skip tests when modules not available" |
| 2 | DESCRIPTION = "Skip test scripts if modules are not available. \ |
| 3 | The requested modules will be loaded, and optionally have their versions \ |
| 4 | checked. If the module is missing, the test script will be skipped. Modules \ |
| 5 | that are found but fail to compile will exit with an error rather than skip." |
| 6 | |
| 7 | HOMEPAGE = "https://metacpan.org/release/Test-Needs" |
| 8 | SECTION = "libs" |
| 9 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 10 | |
| 11 | CPAN_NAME = "Test-Needs" |
| 12 | CPAN_AUTHOR = "HAARG" |
| 13 | |
Brad Bishop | 393846f | 2019-05-20 12:24:11 -0400 | [diff] [blame] | 14 | LIC_FILES_CHKSUM = "file://README;md5=3f3ccd21a0a48aa313db212cc3b1bc09;beginline=88;endline=89" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 15 | |
| 16 | DEPENDS += "perl" |
| 17 | |
Brad Bishop | 393846f | 2019-05-20 12:24:11 -0400 | [diff] [blame] | 18 | SRC_URI = "https://cpan.metacpan.org/authors/id/H/HA/${CPAN_AUTHOR}/${CPAN_NAME}-${PV}.tar.gz" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 19 | |
Brad Bishop | 393846f | 2019-05-20 12:24:11 -0400 | [diff] [blame] | 20 | SRC_URI[md5sum] = "d5c96d51d8d5510f7c0b7f354c49af1c" |
| 21 | SRC_URI[sha256sum] = "77f9fff0c96c5e09f34d0416b3533c3319f7cd0bb1f7fe8f8072ad59f433f0e5" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 22 | |
| 23 | S = "${WORKDIR}/${CPAN_NAME}-${PV}" |
| 24 | |
| 25 | inherit cpan ptest-perl |
| 26 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 27 | RDEPENDS_${PN}-ptest += "perl-module-test-more perl-module-ipc-open3 perl-module-lib perl-module-version" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 28 | |
| 29 | BBCLASSEXTEND = "native" |