Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame^] | 1 | HOMEPAGE = "https://github.com/mchehab/zbar" |
| 2 | SUMMARY = "A bar code library" |
| 3 | DESRIPTION = "ZBar is an open source software suite for reading bar codes \ |
| 4 | from various sources, such as video streams, image files and raw \ |
| 5 | intensity sensors. It supports EAN-13/UPC-A, UPC-E, EAN-8, Code 128, \ |
| 6 | Code 93, Code 39, Codabar, Interleaved 2 of 5, QR Code and SQ Code" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 7 | SECTION = "graphics" |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame^] | 8 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 9 | LICENSE = "LGPL-2.1" |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame^] | 10 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=5e9ee833a2118adc7d8b5ea38e5b1cef" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 11 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame^] | 12 | SRC_URI = "git://github.com/mchehab/zbar.git;branch=master \ |
| 13 | file://0001-qt-Create-subdir-in-Makefile.patch \ |
| 14 | file://0002-zbarcam-Create-subdir-in-Makefile.patch \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 15 | " |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame^] | 16 | SRCREV = "89e7900d85dd54ef351a7ed582aec6a5a5d7fa37" |
| 17 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 18 | S = "${WORKDIR}/git" |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame^] | 19 | PV = "0.23.1+git${SRCPV}" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 20 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame^] | 21 | DEPENDS += "xmlto-native" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 22 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame^] | 23 | PACKAGECONFIG ??= "\ |
| 24 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \ |
| 25 | " |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 26 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame^] | 27 | PACKAGECONFIG ??= "video python3" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 28 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame^] | 29 | inherit autotools pkgconfig gettext \ |
| 30 | ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3native', '', d)} \ |
| 31 | ${@bb.utils.contains('PACKAGECONFIG', 'gtk3', 'gobject-introspection', '', d)} \ |
| 32 | ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'qmake5_paths', '', d)} |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 33 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame^] | 34 | PACKAGECONFIG[x11] = "--with-x, --without-x, libxv" |
| 35 | PACKAGECONFIG[video] = "--enable-video, --disable-video, v4l-utils libv4l" |
| 36 | PACKAGECONFIG[jpeg] = "--with-jpeg, --without-jpeg, jpeg" |
| 37 | PACKAGECONFIG[python3] = "--with-python=auto, --without-python, python3" |
| 38 | PACKAGECONFIG[gtk3] = "--with-gtk=gtk3, --without-gtk, gtk+3" |
| 39 | PACKAGECONFIG[qt5] = "--with-qt5, --without-qt5, qtbase qtbase-native qtx11extras qtsvg, qtbase" |
| 40 | PACKAGECONFIG[imagemagick] = "--with-imagemagick, --without-imagemagick, imagemagick" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 41 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame^] | 42 | FILES_${PN} += "${bindir} \ |
| 43 | ${@bb.utils.contains('DEPENDS', 'python3-native', '${libdir}', '', d)} \ |
| 44 | " |
| 45 | |
| 46 | CPPFLAGS_append = "\ |
| 47 | ${@bb.utils.contains('PACKAGECONFIG', 'qt5', '\ |
| 48 | -I${STAGING_INCDIR}/QtX11Extras \ |
| 49 | -I${STAGING_INCDIR}/dbus-1.0 \ |
| 50 | -I${STAGING_LIBDIR}/dbus-1.0/include \ |
| 51 | ', '', d)} \ |
| 52 | " |
| 53 | |
| 54 | TARGET_CXXFLAGS_append = " -fPIC" |
| 55 | |
| 56 | do_prepare_recipe_sysroot_gettext() { |
| 57 | install -m 755 ${STAGING_DATADIR_NATIVE}/gettext/ABOUT-NLS ${S}/ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 58 | } |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame^] | 59 | addtask do_prepare_recipe_sysroot_gettext after do_prepare_recipe_sysroot before do_configure |