blob: 45962c6ce884f9b7ded1fa957b5ab393e68a66bb [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Foreign Function Interface for Python calling C code"
2HOMEPAGE = "http://cffi.readthedocs.org/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5677e2fdbf7cdda61d6dd2b57df547bf"
5DEPENDS += "libffi ${PYTHON_PN}-pycparser"
6
Andrew Geisslereef63862021-01-29 15:58:13 -06007SRC_URI[sha256sum] = "1a465cbe98a7fd391d47dce4b8f7e5b921e6cd805ef421d04f5f66ba8f06086c"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
9inherit pypi setuptools3
10
11RDEPENDS_${PN}_class-target = " \
12 ${PYTHON_PN}-ctypes \
13 ${PYTHON_PN}-io \
14 ${PYTHON_PN}-pycparser \
15 ${PYTHON_PN}-shell \
16"
17
18BBCLASSEXTEND = "native nativesdk"